Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 03:42
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Картинка в прайсе  (Прочитано 3069 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн TORN

  • *
  • Сообщений: 35
  • РЕПУТАЦИЯ: 3
  • КПД: 9%
  • Регистрация: 2011-09-03
  • Сайт: 
  • Профессия: Бухгалтер
Привет Всем!
Есть справочник товары.В нем есть реквизит - Путь ( полный путь к графическому файлу картинки товара)
Хочу при выводе в прайс-лист вывести картинку товара

Пишу так:
Таб=СоздатьОбъект("Таблица");
Картина=СоздатьОбъект("Картинка");       
Спр=СоздатьОбъект("Справочник.Товары");
Пока Спр.ПолучитьЭлемент()=1 Цикл
Если Спр.ЭтоГруппа()=0 Тогда

    Файл_=СокрЛП(Спр.Путь);
    Если СтрДлина(Файл_)>0  Тогда
        Если ФС.СуществуетФайл(Файл_)=1 Тогда
            Карт.Загрузить(Файл_);
           
        КонецЕсли;
    КонецЕсли;   
    Таб.ВывестиСекцию("Строка");

КонецЕсли;

КонецЦикла;
Таб.Показать();   

В таблице вставляю Таблица/Вставить рисунок/Текст.Потом ему присваиваю идентификатор Карт

Но при выводе ничего не получается((
На форму - где вставлен объект картинка все проходит
Где тут ошибка?


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
alex0402
50 Сообщений
AIFrame
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 124
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal