Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 18:11
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Заполнение ячейки макета. Подскажите пожалуйста?  (Прочитано 8481 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн BlackCat

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-08-29
  • Сайт: 
  • Профессия: Программист 1С
Здравствуйте! Мне надо программно заполнить ячейки макета прочерками в печатных формах. Я туда ставлю прочерки, но не знаю как можно программно поставить их в середину ячейки. Подскажите есть ли такая функция? Макет не трогаю, т.к. если там надписи, то они должны идти от края ячейки.


Оффлайн BlackCat

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-08-29
  • Сайт: 
  • Профессия: Программист 1С
Осталось 30 мин на решение проблемы, плиз подскажите?

Оффлайн BlackCat

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-08-29
  • Сайт: 
  • Профессия: Программист 1С

Оффлайн cannabis_86

  • ***
  • Сообщений: 168
  • РЕПУТАЦИЯ: 19
  • КПД: 11%
  • Регистрация: 2010-08-26
  • Сайт: 
ОбластьЗаголовок.Область("R14C1:R14C3").ГоризонтальноеПоложение = ГоризонтальноеПоложение.Центр
Это?

Оффлайн BlackCat

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-08-29
  • Сайт: 
  • Профессия: Программист 1С
Спасибо! Наверно так, но не получается у меня обратиться к ячейке. Вот моя процедура:

Процедура ПоставитьПрочеркиГдеПусто(ОбластьМакета)
   Инд = 0;
   Для Инд = 0 по ОбластьМакета.Параметры.Количество() - 1 Цикл
      Если Не ЗначениеЗаполнено(ОбластьМакета.Параметры.Получить(Инд)) Тогда
         ОбластьМакета.Параметры.Установить(Инд, " - - - -");
      КонецЕсли;
   КонецЦикла;
   
КонецПроцедуры

Подскажите пожалуйста как к ячейке обратиться?

Оффлайн BlackCat

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-08-29
  • Сайт: 
  • Профессия: Программист 1С
Люди очень надо, неужели никто не знает? К клиенту уже еду((((

Оффлайн cannabis_86

  • ***
  • Сообщений: 168
  • РЕПУТАЦИЯ: 19
  • КПД: 11%
  • Регистрация: 2010-08-26
  • Сайт: 
В данном случае вы обращаетесь к параметру, тут как я описывал будет тяжело сделать, в связи с тем, что вы не знаете точный номер ячейки, где находится данный параметр. Предлагаю сразу в макете сделать в ячейке, в которой находится параметр установить Горизонтальное положение в центр через свойства ячейки.


Теги:
 

Заполнение табл. части документа из табл. части другого документа

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 11
Просмотров: 7578
Последний ответ 16 Авг 2012, 21:50
от Will
Заполнение табличной части документа табличной частью из другого документа

Автор PeaceownerРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2536
Последний ответ 30 Ноя 2011, 07:10
от has
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 15929
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4199
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 629
Последний ответ 10 Май 2017, 20:44
от ilnur75

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
184 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
40 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 508
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal