Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Май 2018, 10:16
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Проблемы с отчетом  (Прочитано 2045 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн kailRiss

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 1
  • КПД: 8%
  • Регистрация: 2011-09-12
  • Сайт: 
  • Профессия: Программист 8.1
Суть вопроса в том как добавить в отчет ТабличнуюЧасть а не только Реквизиты, создал переменную с данными : ТабЧасть = Справочники.ФизческиеЛица.Выбрать().ТрудоваяДеятельность;

Тут через нее передать данные хотел : ОТабЧасти.Параметры.НачалоРаботы = ТабЧасть.НачалоРаботы;
Выдает ошибку : Значение не является значением объекта типа (Организация)
Как правильно скормить данные???

Полностью Процедура

Процедура ДействияФормыПечатьОтчета(Кнопка)
   
Макет = Справочники.ФизческиеЛица.ПолучитьМакет("Информация");
ОбластьШапка = Макет.ПолучитьОбласть("Шапка");
ТабДок = Новый ТабличныйДокумент;
ТабДок.Вывести(ОбластьШапка);
Выборка = Справочники.ФизческиеЛица.Выбрать();
ТабЧасть = Справочники.ФизческиеЛица.Выбрать().ТрудоваяДеятельность;
                                 
Пока Выборка.Следующий() Цикл
   Если Выборка.ЭтоГруппа=Истина Тогда
         Иначе
      ОТабЧасти = Макет.ПолучитьОбласть("ФИО_1");
      ОТабЧасти.Параметры.Фамилия = Выборка.Фамилия;
      ОТабЧасти.Параметры.Имя = Выборка.Имя;
      ОТабЧасти.Параметры.Отчество = Выборка.Отчество;
      ОТабЧасти.Параметры.ДатаРождения = Выборка.ДатаРождения;
      ОТабЧасти.Параметры.НачалоРаботы = ТабЧасть.НачалоРаботы;
            
            
         КонецЕсли;
   ТабДок.Вывести(ОТабЧасти);
КонецЦикла;
ТабДок.Показать();
   
КонецПроцедуры


Оффлайн Kras

  • *
  • Сообщений: 14
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-12
  • Сайт: 
  • Профессия: Программист 1С
так Запрос напишите и выберите табл.часть
например так
ВЫБРАТЬ
   ФизическиеЛицаТрудоваяДеятельность.Ссылка.Код,
   ФизическиеЛицаТрудоваяДеятельность.Ссылка.Наименование,
   ФизическиеЛицаТрудоваяДеятельность.Ссылка.ДатаРождения,
   ФизическиеЛицаТрудоваяДеятельность.Организация,
   ФизическиеЛицаТрудоваяДеятельность.ДатаНачала,
   ФизическиеЛицаТрудоваяДеятельность.ДатаОкончания,
   ФизическиеЛицаТрудоваяДеятельность.Должность
ИЗ
   Справочник.ФизическиеЛица.ТрудоваяДеятельность КАК ФизическиеЛицаТрудоваяДеятельность

Оффлайн Kras

  • *
  • Сообщений: 14
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-12
  • Сайт: 
  • Профессия: Программист 1С
и загоняйте нужные данные в макет


Теги:
 

Закрытие 97 счета, проблемы с закрытием 97 счета в НУ

Автор LisenokkРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 7206
Последний ответ 20 Июн 2011, 20:39
от Lisenokk
Управление торговлей и управление складом. Проблемы обмена данными.

Автор CabinetonlineРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3355
Последний ответ 12 Мар 2013, 12:54
от Slin
Обмен данными. Правила обмена данными. Проблемы с повторной выгрузкой.

Автор 1cdpРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 5934
Последний ответ 02 Авг 2011, 18:29
от 1cdp
Проблема с отчетом "Перемещение товаров"

Автор sailРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3679
Последний ответ 14 Дек 2010, 20:27
от progmikon
1C 8.2 УПП проблема с отчетом "Задолженость по контрагентам"

Автор LeonidLeonidРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3996
Последний ответ 26 Сен 2011, 20:42
от Dethmontt

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
alex0402
69 Сообщений
oleg-x
68 Сообщений
AIFrame AIFrame
59 Сообщений
wise wise
39 Сообщений
buketov.av buketov.av
39 Сообщений
KOI8-R
34 Сообщений
ilyay ilyay
29 Сообщений
Alter
28 Сообщений
trialex3
25 Сообщений

* Кто онлайн

  • Точка Гостей: 733
  • Точка Скрытых: 0
  • Точка Пользователей: 15
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal