Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 23:09
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Проблемы с отчетом  (Прочитано 1865 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн kailRiss

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 1
  • КПД: 8%
  • Регистрация: 2011-09-12
  • Сайт: 
  • Профессия: Программист 8.1
Суть вопроса в том как добавить в отчет ТабличнуюЧасть а не только Реквизиты, создал переменную с данными : ТабЧасть = Справочники.ФизческиеЛица.Выбрать().ТрудоваяДеятельность;

Тут через нее передать данные хотел : ОТабЧасти.Параметры.НачалоРаботы = ТабЧасть.НачалоРаботы;
Выдает ошибку : Значение не является значением объекта типа (Организация)
Как правильно скормить данные???

Полностью Процедура

Процедура ДействияФормыПечатьОтчета(Кнопка)
   
Макет = Справочники.ФизческиеЛица.ПолучитьМакет("Информация");
ОбластьШапка = Макет.ПолучитьОбласть("Шапка");
ТабДок = Новый ТабличныйДокумент;
ТабДок.Вывести(ОбластьШапка);
Выборка = Справочники.ФизческиеЛица.Выбрать();
ТабЧасть = Справочники.ФизческиеЛица.Выбрать().ТрудоваяДеятельность;
                                 
Пока Выборка.Следующий() Цикл
   Если Выборка.ЭтоГруппа=Истина Тогда
         Иначе
      ОТабЧасти = Макет.ПолучитьОбласть("ФИО_1");
      ОТабЧасти.Параметры.Фамилия = Выборка.Фамилия;
      ОТабЧасти.Параметры.Имя = Выборка.Имя;
      ОТабЧасти.Параметры.Отчество = Выборка.Отчество;
      ОТабЧасти.Параметры.ДатаРождения = Выборка.ДатаРождения;
      ОТабЧасти.Параметры.НачалоРаботы = ТабЧасть.НачалоРаботы;
            
            
         КонецЕсли;
   ТабДок.Вывести(ОТабЧасти);
КонецЦикла;
ТабДок.Показать();
   
КонецПроцедуры


Оффлайн Kras

  • *
  • Сообщений: 14
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-12
  • Сайт: 
  • Профессия: Программист 1С
так Запрос напишите и выберите табл.часть
например так
ВЫБРАТЬ
   ФизическиеЛицаТрудоваяДеятельность.Ссылка.Код,
   ФизическиеЛицаТрудоваяДеятельность.Ссылка.Наименование,
   ФизическиеЛицаТрудоваяДеятельность.Ссылка.ДатаРождения,
   ФизическиеЛицаТрудоваяДеятельность.Организация,
   ФизическиеЛицаТрудоваяДеятельность.ДатаНачала,
   ФизическиеЛицаТрудоваяДеятельность.ДатаОкончания,
   ФизическиеЛицаТрудоваяДеятельность.Должность
ИЗ
   Справочник.ФизическиеЛица.ТрудоваяДеятельность КАК ФизическиеЛицаТрудоваяДеятельность

Оффлайн Kras

  • *
  • Сообщений: 14
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-12
  • Сайт: 
  • Профессия: Программист 1С
и загоняйте нужные данные в макет


Теги:
 

Закрытие 97 счета, проблемы с закрытием 97 счета в НУ

Автор LisenokkРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 6848
Последний ответ 20 Июн 2011, 20:39
от Lisenokk
Управление торговлей и управление складом. Проблемы обмена данными.

Автор CabinetonlineРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3029
Последний ответ 12 Мар 2013, 12:54
от Slin
Обмен данными. Правила обмена данными. Проблемы с повторной выгрузкой.

Автор 1cdpРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 5351
Последний ответ 02 Авг 2011, 18:29
от 1cdp
Проблема с отчетом "Перемещение товаров"

Автор sailРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3319
Последний ответ 14 Дек 2010, 20:27
от progmikon
1C 8.2 УПП проблема с отчетом "Задолженость по контрагентам"

Автор LeonidLeonidРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3574
Последний ответ 26 Сен 2011, 20:42
от Dethmontt

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
170 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
49 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 299
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal