Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 13:12
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Управляемая форма, вставить фото  (Прочитано 10490 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн forumlarin

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-08-31
  • Сайт: 
Создал справочник сотрудники, добавил реквизит фото, добавил Форму элемента справочника, на форме элемента у реквизита Фото сделал вид "Поле картинки", подскажите как делать дальше ?


Оффлайн comol

  • ****
  • Сообщений: 285
  • РЕПУТАЦИЯ: 38
  • КПД: 13%
  • Регистрация: 2011-09-08
  • Сайт: comol.livejournal.com
  • Профессия: Программист 1С
УТ 11 справочник номенклатуры посмотрите
Статьи по оптимизации 1С: http://comol.livejournal.com/

Оффлайн forumlarin

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-08-31
  • Сайт: 
Смотрел для меня все связать в едино сложно

Оффлайн forumlarin

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-08-31
  • Сайт: 
Можно примерчик

Оффлайн ilyay

  • 1С:Специалист, 1С:Эксперт
  • ****
  • Сообщений: 473
  • РЕПУТАЦИЯ: 85
  • КПД: 18%
  • Регистрация: 2011-06-09
  • Сайт: 
  • Профессия: Разработчик 1С
На форме - поле картинки, путь к данным АдресКартинки
Реквизит формы - Адрес картинки типа Строка, длина 0
На форме кнопка к команде. Код команды:

   Перем ВыбранноеИмя,АдресВременногоХранилища;
   Если ПоместитьФайл(АдресВременногоХранилища, "", ВыбранноеИмя, Истина, УникальныйИдентификатор) Тогда
      АдресКартинки = АдресВременногоХранилища;
      Модифицированность = Истина;
   КонецЕсли;

У меня фотография хранится в подчиненном справочнике "Фотобанк", чтобы не перегружать объемом данных основной справочник.
реквизиты: фото (хранилищезначения) и основноефото (булево)

Форма - ПриЗаписиНаСервере:
   ЗаписьФотографии(АдресКартинки, ТекущийОбъект.Ссылка);

&НаСервере
Процедура ЗаписьФотографии(АдресКартинки, СсылкаНаТекущийОбъект)
   
   СсылкаНаОбъектФотобанка = Справочники.Фотобанк.НайтиПоРеквизиту("ОсновноеФото", Истина,, СсылкаНаТекущийОбъект);      
   Если ЭтоАдресВременногоХранилища(АдресКартинки) Тогда
      ДвоичныеДанные = ПолучитьИзВременногоХранилища(АдресКартинки);
      Если СсылкаНаОбъектФотобанка = Справочники.Фотобанк.ПустаяСсылка() Тогда
         ОбъектФотобанка = Справочники.Фотобанк.СоздатьЭлемент();
         ОбъектФотобанка.Владелец = СсылкаНаТекущийОбъект;
         ОбъектФотобанка.ОсновноеФото = Истина;
      Иначе
         ОбъектФотобанка = СсылкаНаОбъектФотобанка.ПолучитьОбъект();
      КонецЕсли;
      ОбъектФотобанка.Фото = Новый ХранилищеЗначения(ДвоичныеДанные, Новый СжатиеДанных());
      ОбъектФотобанка.Записать();
      
      СсылкаНаОбъектФотобанка = ОбъектФотобанка.Ссылка;
      УдалитьИзВременногоХранилища(АдресКартинки);
   КонецЕсли;   
   
   АдресКартинки = ПолучитьНавигационнуюСсылку(СсылкаНаОбъектФотобанка, "Фото");
   
КонецПроцедуры




Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
55 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 272
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal