Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
28 Май 2018, 08:21
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Управляемая форма, вставить фото  (Прочитано 11222 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн forumlarin

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-08-31
  • Сайт: 
Создал справочник сотрудники, добавил реквизит фото, добавил Форму элемента справочника, на форме элемента у реквизита Фото сделал вид "Поле картинки", подскажите как делать дальше ?


Оффлайн comol

  • ****
  • Сообщений: 285
  • РЕПУТАЦИЯ: 38
  • КПД: 13%
  • Регистрация: 2011-09-08
  • Сайт: comol.livejournal.com
  • Профессия: Программист 1С
УТ 11 справочник номенклатуры посмотрите
Статьи по оптимизации 1С: http://comol.livejournal.com/

Оффлайн forumlarin

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-08-31
  • Сайт: 
Смотрел для меня все связать в едино сложно

Оффлайн forumlarin

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-08-31
  • Сайт: 
Можно примерчик

Оффлайн ilyay

  • 1С:Специалист, 1С:Эксперт
  • *****
  • Сообщений: 520
  • РЕПУТАЦИЯ: 94
  • КПД: 18%
  • Регистрация: 2011-06-09
  • Сайт: 
  • Профессия: Разработчик 1С
На форме - поле картинки, путь к данным АдресКартинки
Реквизит формы - Адрес картинки типа Строка, длина 0
На форме кнопка к команде. Код команды:

   Перем ВыбранноеИмя,АдресВременногоХранилища;
   Если ПоместитьФайл(АдресВременногоХранилища, "", ВыбранноеИмя, Истина, УникальныйИдентификатор) Тогда
      АдресКартинки = АдресВременногоХранилища;
      Модифицированность = Истина;
   КонецЕсли;

У меня фотография хранится в подчиненном справочнике "Фотобанк", чтобы не перегружать объемом данных основной справочник.
реквизиты: фото (хранилищезначения) и основноефото (булево)

Форма - ПриЗаписиНаСервере:
   ЗаписьФотографии(АдресКартинки, ТекущийОбъект.Ссылка);

&НаСервере
Процедура ЗаписьФотографии(АдресКартинки, СсылкаНаТекущийОбъект)
   
   СсылкаНаОбъектФотобанка = Справочники.Фотобанк.НайтиПоРеквизиту("ОсновноеФото", Истина,, СсылкаНаТекущийОбъект);      
   Если ЭтоАдресВременногоХранилища(АдресКартинки) Тогда
      ДвоичныеДанные = ПолучитьИзВременногоХранилища(АдресКартинки);
      Если СсылкаНаОбъектФотобанка = Справочники.Фотобанк.ПустаяСсылка() Тогда
         ОбъектФотобанка = Справочники.Фотобанк.СоздатьЭлемент();
         ОбъектФотобанка.Владелец = СсылкаНаТекущийОбъект;
         ОбъектФотобанка.ОсновноеФото = Истина;
      Иначе
         ОбъектФотобанка = СсылкаНаОбъектФотобанка.ПолучитьОбъект();
      КонецЕсли;
      ОбъектФотобанка.Фото = Новый ХранилищеЗначения(ДвоичныеДанные, Новый СжатиеДанных());
      ОбъектФотобанка.Записать();
      
      СсылкаНаОбъектФотобанка = ОбъектФотобанка.Ссылка;
      УдалитьИзВременногоХранилища(АдресКартинки);
   КонецЕсли;   
   
   АдресКартинки = ПолучитьНавигационнуюСсылку(СсылкаНаОбъектФотобанка, "Фото");
   
КонецПроцедуры




Теги:
 

Печатная форма "ЧекККМ" для "Отчета о розничных продажах"

Автор Игорь ПолищукРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 7519
Последний ответ 01 Июн 2011, 20:39
от Шурыгин Иван Сергеевич
УТ 11.3 форма "УправлениеЭквайринговымТерминалом"

Автор skelaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 240
Последний ответ 09 Фев 2018, 21:23
от Геннадий ОбьГЭС
Внешняя обработка (внешняя печатная форма УТ ЗаказПокупателя)

Автор RusadmРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4576
Последний ответ 27 Май 2011, 15:23
от cska-fanat-kz
Печатная форма "Акт сверки взаиморасчетов"

Автор NikolosРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4632
Последний ответ 11 Сен 2012, 08:18
от Nikolos
Форма "Взнос наличными в банк" где она :)

Автор lefantiy_94Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 5548
Последний ответ 30 Июн 2015, 03:50
от lefantiy_94

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
139 Сообщений
alex0402
64 Сообщений
oleg-x
54 Сообщений
AIFrame AIFrame
53 Сообщений
buketov.av buketov.av
47 Сообщений
ilyay ilyay
39 Сообщений
wise wise
37 Сообщений
Анюта17
33 Сообщений
Alter
32 Сообщений
alexandr_ll
32 Сообщений

* Кто онлайн

  • Точка Гостей: 427
  • Точка Скрытых: 0
  • Точка Пользователей: 9
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal