Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 05:45
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Вопрос по методу ПолучитьФайл()  (Прочитано 46636 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн E_x

  • *
  • Сообщений: 44
  • РЕПУТАЦИЯ: 2
  • КПД: 5%
  • Регистрация: 2011-09-12
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте. Вот вопрос: "Как можно отловить нажатие кнопки в интерактивном режиме(имею в виду кнопку открыть или сохранить). Т.к. при нажатии на кнопку Открыть - файл сохраняется во временную папку и запускается, а при нажатии на кнопку Сохранить - открывается диалог сохранения файла и все. А мне надо обязательно открыть этот файл, поэтому считаю, что у этой проблемы 2 решения: 1. Заблокировать кнопку Сохранить (чтобы только кнопка Открыть была доступна). 2. Отлавливать нажатие кнопки, чтобы выяснить что выбрал пользователь."
 
p.s. не судите строго, я начинающий программист, 1с изучаю всего месяц, поэтому чего-то могу не знать. Заранее благодарю всех за помощь :)
Будь собой - прочие роли заняты!


Оффлайн cannabis_86

  • ***
  • Сообщений: 168
  • РЕПУТАЦИЯ: 19
  • КПД: 11%
  • Регистрация: 2010-08-26
  • Сайт: 
Не совсем понятно, что хотите. Какая конфигурация? Платформа? Где вы нажимаете кнопки(форма документа, обработки и т.п.)? И объясните лучше задачу, непосредственно - нужно сделать сохранение и открытие файлов в базе, прикрепление файлов к документам, справочникам и т.п.

Оффлайн E_x

  • *
  • Сообщений: 44
  • РЕПУТАЦИЯ: 2
  • КПД: 5%
  • Регистрация: 2011-09-12
  • Сайт: 
  • Профессия: Ученик 1С
Конфигурацию создаю сам, с 0. Платформа 8.2.
Описываю суть(на вложенной картинке пронумировал формы,чтобы было понятнее какая за какой идет):
Открывается форма документа (1)
После заполнения нажимается кнопка "Запросить Удаленное подключение" и открывается форма "Предупреждение"(2)
При нажатии на кнопку "Да" открывается форма выбора запуска программы (3)
При выборе Загрузить и Запустить вызывается метод ПолучитьФайл() и открывается интерактивная форма(4)

Суть такова: при выборе пункта Загрузить и запустить файл обязательно должен запуститься(при выборе на интерактивной форме кнопки Открыть так и происходит, а при выборе кнопки Сохранить он просто сохраняется и все). Писал дополнительно функцию открытия файла после этого выбора, но появилась проблема: если пользователь выбрал пункт Открыть, то программа запускается + появляется окно выбора файла для запуска(сами понимаете, что это глупо). Вот я и пытаюсь решить эту проблему.

Никаких прикреплений файла не происходит, т.к. файл скачивается из интернета, помещается во временную папку и от туда запускается. Файл имеет расширение exe. Думаю понятно объяснил все. Если нет, постараюсь еще раз объяснить, чтобы понятно было:)
Будь собой - прочие роли заняты!

Оффлайн cannabis_86

  • ***
  • Сообщений: 168
  • РЕПУТАЦИЯ: 19
  • КПД: 11%
  • Регистрация: 2010-08-26
  • Сайт: 
Скорее всего нужно отключить в функции открытия файла СтандартнаяОбработка = Ложь. Хотя точно утверждать не могу. В принципе вы можете и не использовать интерактивный режим, а сделать свои формы и сделать так как вам нужно.

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Я вот вобще ничего не понял. Щас проблема в том, что не нужен диалог выбора файла чтоли? Или не можешь узнать какой вариант из "Запустить" и "Запустить и загрузить" выбрал пользователь?

Оффлайн E_x

  • *
  • Сообщений: 44
  • РЕПУТАЦИЯ: 2
  • КПД: 5%
  • Регистрация: 2011-09-12
  • Сайт: 
  • Профессия: Ученик 1С
cannabis_86Можно написать, но метод ПолучитьФайл() проще в том плане, что все автоматически уже сделано. Я пытался сначала отдельно написать функцию скачивания файла, но возникли некоторые проблемы(например файл с нужным именем создавался в заданной директории, но размер файла был 0 байт).

запуск = новый HTTPСоединение("http://1castrakhan.ru/");
запуск.Получить("http://1castrakhan.ru/TeamViewerQS.exe","TeamViewerQS.exe");

has, проблема в том, что надо как-то узнать какую кнопку нажал пользователь на интерактивной форме (Открыть или Сохранить) ну или как-то заблокировать кнопку Сохранить на этой форме. Форма автоматическая, программа сама генерирует ее.
Будь собой - прочие роли заняты!

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Покажи код. Где и как открывается твоя интерактивная форма.

Оффлайн E_x

  • *
  • Сообщений: 44
  • РЕПУТАЦИЯ: 2
  • КПД: 5%
  • Регистрация: 2011-09-12
  • Сайт: 
  • Профессия: Ученик 1С
&НаКлиенте
Процедура ОК(Команда)
Если ВидЗапускаПО = 0 тогда
путь=общиепроцедуры.ИмяФайла();
Если ЗначениеЗаполнено(путь) Тогда
запуститьприложение(путь);
КонецЕсли;
ИначеЕсли ВидЗапускаПО = 1 тогда
Если ПолучитьФайл("http://1castrakhan.ru/TeamViewerQS.exe", "TeamViewerQS.exe", Истина) тогда
предупреждение("ИСТИНА",0);
иначе
    предупреждение("ЛОЖЬ",0);
КонецЕсли;
КонецЕсли;
этаформа.Закрыть();
КонецПроцедуры
Будь собой - прочие роли заняты!

Оффлайн E_x

  • *
  • Сообщений: 44
  • РЕПУТАЦИЯ: 2
  • КПД: 5%
  • Регистрация: 2011-09-12
  • Сайт: 
  • Профессия: Ученик 1С
может я немного не правильно выразился, может форма не интерактивная.. В справке по методу ПолучитьФайл() написано:

Цитировать
<Интерактивно> (необязательный)
Тип: Булево. Истина - режим, в котором пользователю показывается диалог, в котором он может выбрать действие с получаемым файлом: запустить его или сохранить по выбранному расположению.
Вот благодаря этому свойству и появляется автоматическая форма. Извините если я назвал ее интерактивной, а она таковой и не является...
Будь собой - прочие роли заняты!

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Сделал бы свою форму, там и все обработчики как надо написал.


Теги:
 

Возможно ли получение эталонного файла конфигурации *.cf из измененной стандартной, например (УТ 11.1, БП 3.0) или вопрос о том как убрать лишние доработки и привести конфигурацию базы максимально к стандартной после варварских "доработок"?

Автор kostyaomskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 9198
Последний ответ 30 Дек 2015, 22:14
от 1Cnastroika
Вопрос по РИБ "ПоОрганизации"

Автор andi_xРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 5842
Последний ответ 15 Мар 2013, 21:38
от Besart
Вопрос по "Отчеты о Розничных продажах".

Автор GerCerberРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3288
Последний ответ 26 Июл 2010, 16:06
от crow1983
Вопрос о действии кнопки "Записать"

Автор jenya1111Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 3434
Последний ответ 06 Окт 2014, 15:23
от jenya1111
Вопрос по отчету "Материалы в эксплуатации".

Автор mitauskasРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 2362
Последний ответ 04 Мар 2015, 11:07
от Дмитрий@

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
175 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
alex0402
44 Сообщений
AIFrame
39 Сообщений
andron81_81
38 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 287
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal