Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
27 Май 2018, 16:58
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: При Изменении Склада Получать Список Материально Ответственного лица  (Прочитано 5476 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Шурик_1985

  • *
  • Сообщений: 44
  • РЕПУТАЦИЯ: 5
  • КПД: 11%
  • )
  • Регистрация: 2011-05-14
  • Сайт: 
  • Профессия: Ученик 1С
Есть Справочник Склад, реквизит МОЛ (Материально Ответственного Лицо) ТипСправочники.Сотрудники
Есть Документ Перемещение с Реквизитом СкладОтправитель и СотрудникОтправитель
Хочу при изменении склада в реквизите СотрудникОтправитель получал МОЛ

Попробовал это Вариант
&НаКлиенте
Процедура СкладОтправительПриИзменении(Элемент)
   Если Объект.СотрудникПолучатель.Пустая()Тогда
       Выбрать = Справочники.Склад.НайтиПоРеквизиту("МОЛ");
   КонецЕсли;
   
   КонецПроцедуры
 :befhbt:
Усё чотко!


Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1310
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
А если так?
&НаКлиенте
Процедура СкладОтправительПриИзменении(Элемент)
   Если ЗначениеЗаполнено(Объект.СкладОтправитель) Тогда
      Объект.СотрудникОтправитель = ПолучитьСотрудника(Объект.СкладОтправитель);
   КонецЕсли;
КонецПроцедуры

&НаСервереБезКонтекста
Функция ПолучитьСотрудника(Склад)
   Возврат Склад.Мол;
КонецФункции

Оффлайн Шурик_1985

  • *
  • Сообщений: 44
  • РЕПУТАЦИЯ: 5
  • КПД: 11%
  • )
  • Регистрация: 2011-05-14
  • Сайт: 
  • Профессия: Ученик 1С
А если так?
&НаКлиенте
Процедура СкладОтправительПриИзменении(Элемент)
   Если ЗначениеЗаполнено(Объект.СкладОтправитель) Тогда
      Объект.СотрудникОтправитель = ПолучитьСотрудника(Объект.СкладОтправитель);
   КонецЕсли;
КонецПроцедуры

&НаСервереБезКонтекста
Функция ПолучитьСотрудника(Склад)
   Возврат Склад.Мол;
КонецФункции

Попробовал как вы написали в итоге вот что пишет:
{Документ.Перемещение.Форма.ФормаДокумента.Форма(17,5)}: Неопознанный оператор
      <<?>>&НаСервереБезКонтекста (Проверка: Сервер)
{Документ.Перемещение.Форма.ФормаДокумента.Форма(1,1)}: Обнаружено логическое завершение исходного текста модуля (Проверка: Сервер)
{Документ.Перемещение.Форма.ФормаДокумента.Форма(17,5)}: Неопознанный оператор
      <<?>>&НаСервереБезКонтекста (Проверка: Тонкий клиент)
{Документ.Перемещение.Форма.ФормаДокумента.Форма(1,1)}: Обнаружено логическое завершение исходного текста модуля (Проверка: Тонкий клиент)
Усё чотко!

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1310
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Платформа 8.2? Управляемые формы? А другого кода нет в модуле?


Теги:
 

Что такое "Список Значений", "Таблица значений" и "Дерево Значений"?

Автор JahongirРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 7650
Последний ответ 23 Дек 2011, 16:43
от sergeevds
Массив, Таблица значений и Список значений

Автор Константин163Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 7326
Последний ответ 25 Мар 2015, 16:02
от cska-fanat-kz
Дин.список отбор данных - не работает код при тех же данных

Автор Аля ТинаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 368
Последний ответ 15 Дек 2017, 14:36
от alex0402
Автозаполнение поля табличной части документа при изменении другого поля табличной части документа

Автор dimanpspРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 17
Просмотров: 5282
Последний ответ 02 Июн 2015, 15:53
от dimanpsp
Как из справочника вытащить список одной группы справочника и вставить его в поле документа для выбора одного элемента из полученного списка?

Автор ilnur75Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 1987
Последний ответ 21 Сен 2016, 08:16
от GadLex

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
alex0402
67 Сообщений
oleg-x
56 Сообщений
AIFrame AIFrame
56 Сообщений
buketov.av buketov.av
47 Сообщений
wise wise
41 Сообщений
ilyay ilyay
39 Сообщений
Анюта17
33 Сообщений
Alter
32 Сообщений
alexandr_ll
30 Сообщений

* Кто онлайн

  • Точка Гостей: 241
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal