Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 16:24
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: ТЧ на форме загрузить, сохранив ТекСтр  (Прочитано 1985 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн bolobol

  • *
  • Сообщений: 41
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-08-26
  • Сайт: 
  • Профессия: Программист 1С
Здравствуйте!

Есть в обработке табличная часть Ведомости, размещённая на форме. Как только происходит оплата ведомости, список оставшихся должен обновиться, но курсор должен остаться в той же строке, табличная часть опять оказаться активной для ввода с клавиатуры.
Я сделал это следующим образом, но, что-то мне подсказывает, что даже для 1С - это очень жёстко ))

Может, присоветуете чего. Спасибо.

ТекСтр= ЭлементыФормы.Ведомости.ТекущаяСтрока;
Если ТекСтр <> Неопределено Тогда
    ТекСтр= ТекСтр.НомерСтроки;
КонецЕсли;
Ведомости.Загрузить(Запрос.Выполнить().Выгрузить());
Если ТекСтр <> Неопределено Тогда
    ЭлементыФормы.Ведомости.ТекущаяСтрока= Ведомости[ТекСтр -1];
    ЭтаФорма.ТекущийЭлемент= ЭлементыФормы.Ведомости;
КонецЕсли;


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Да в принципе все нормально.
Но я сделал бы вот так -
ТекСтр= ЭлементыФормы.Ведомость.ТекущаяСтрока;
Если ТекСтр <> Неопределено Тогда
    Индекс = Ведомость.Индекс(ТекСтр);
КонецЕсли;

Ведомость.Загрузить(Запрос.Выполнить().Выгрузить());
Если Индекс <> Неопределено Тогда
ЭлементыФормы.Ведомость.ТекущаяСтрока= Ведомость[Индекс];
ЭтаФорма.ТекущийЭлемент= ЭлементыФормы.Ведомость;
КонецЕсли;
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн bolobol

  • *
  • Сообщений: 41
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-08-26
  • Сайт: 
  • Профессия: Программист 1С
Самое интересное, что в обоих вариантах нет проверки на наличие необходимого количества строк... Долго смеялся ))


Теги:
 

Группа "СписокКомпоновщикНастроекПользовательскиеНастройки" в форме "Перечисления"

Автор Азамат ХубиевРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1752
Последний ответ 12 Ноя 2016, 18:08
от Азамат Хубиев
Изменение цвета при подборе сотрудника в форме списка справочника "Сотрудники организации" для документа "Зарплата к выплате организаций" ЗУП 2.5

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 263
Последний ответ 12 Окт 2017, 14:02
от wise
Как настроить отображение на форме "группа плательщика единого налога" при выборе системы налогообложения "Единый налог"?

Автор Nicolayci91Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2271
Последний ответ 17 Авг 2015, 07:48
от cska-fanat-kz
Добавление строки и заполнение строки в ТЗ на форме

Автор Св ЧРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 283
Последний ответ 25 Сен 2017, 09:00
от Св Ч
Ребята, срочно нужна помощь. Какую процедуру нужно написать в форме справочника, чтобы таблица заполнялась данными из другого справочника?

Автор Олька БякинаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2751
Последний ответ 27 Май 2016, 15:19
от Олька Бякина

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
163 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 801
  • Точка Скрытых: 0
  • Точка Пользователей: 12
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal