Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
16 сен 2021, 19:18

ТЧ на форме загрузить, сохранив ТекСтр

Автор bolobol, 14 сен 2011, 22:50

0 Пользователей и 1 гость просматривают эту тему.

bolobol

Здравствуйте!

Есть в обработке табличная часть Ведомости, размещённая на форме. Как только происходит оплата ведомости, список оставшихся должен обновиться, но курсор должен остаться в той же строке, табличная часть опять оказаться активной для ввода с клавиатуры.
Я сделал это следующим образом, но, что-то мне подсказывает, что даже для 1С - это очень жёстко ))

Может, присоветуете чего. Спасибо.


ТекСтр= ЭлементыФормы.Ведомости.ТекущаяСтрока;
Если ТекСтр <> Неопределено Тогда
    ТекСтр= ТекСтр.НомерСтроки;
КонецЕсли;
Ведомости.Загрузить(Запрос.Выполнить().Выгрузить());
Если ТекСтр <> Неопределено Тогда
    ЭлементыФормы.Ведомости.ТекущаяСтрока= Ведомости[ТекСтр -1];
    ЭтаФорма.ТекущийЭлемент= ЭлементыФормы.Ведомости;
КонецЕсли;

Dethmontt

Да в принципе все нормально.
Но я сделал бы вот так -
ТекСтр= ЭлементыФормы.Ведомость.ТекущаяСтрока;
Если ТекСтр <> Неопределено Тогда
    Индекс = Ведомость.Индекс(ТекСтр);
КонецЕсли;

Ведомость.Загрузить(Запрос.Выполнить().Выгрузить());
Если Индекс <> Неопределено Тогда
ЭлементыФормы.Ведомость.ТекущаяСтрока= Ведомость[Индекс];
ЭтаФорма.ТекущийЭлемент= ЭлементыФормы.Ведомость;
КонецЕсли;
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

bolobol

Самое интересное, что в обоих вариантах нет проверки на наличие необходимого количества строк... Долго смеялся ))

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск