Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 18:11
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Доработка отчета ЛС_бюджетный (7.7.027) ББУ (646)  (Прочитано 2626 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн roslakov

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-12-06
  • Сайт: 
  • Профессия: Программист 8.1
Здравствуйте! Задача: Доработать отчет ЛС_бюджетный что бы данные выводились в разрезе контрагентов. Для этого на 206-е и 500-е счета было добавлено субконто КонтрагентыРазрез (Тип:Справочник.Контрагенты) и изменен модуль формы данного отчета, и его таблица(добавлена колонка КонтрагентыРазрез). При формировании отчета выдается ошибка: Поле агрегатного объекта не обнаружено (Контрагенты) и отчет не формируется. Подскажите пожалуйста что не так делаю.
Привожу чась кода:


Процедура ПолучитьЛБО(Сч, Ксч, i, РУ="", Лсч = 1, ЛБО = 1)

Ит = СоздатьОбъект("БухгалтерскиеИтоги");
Ит.ИспользоватьСубконто(ВидыСубконто.ФКР);
Ит.ИспользоватьСубконто(ВидыСубконто.ОГС);

д=2;

//******************+++
Если (ДетЭКР = 1) и (i = 2) Тогда
Ит.ИспользоватьСубконто(ВидыСубконто.ДетализацияЭКР);
д=д+1;

КонецЕсли;
//******************--- 
Если Лсч = 1 Тогда
Ит.ИспользоватьСубконто(ВидыСубконто.ЛицевыеСчета,ЛицевойСчет,2);
д=д+1;
КонецЕсли;

//Испр СМ
Ит.ИспользоватьСубконто(ВидыСубконто.КонтрагентыРазрез);
д=д+1;
//Кон Испр

Если ПустоеЗначение(РУ)=0 Тогда
Ит.ИспользоватьРазделительУчета(РУ);
КонецЕсли;

Ит.ВыполнитьЗапрос(НачГода(НаДату),НаДату,Сч,КСч,,2);
Ит.ВыбратьСубконто(д);
//Испр СМ


Пока Ит.ПолучитьСубконто(д)= 1 Цикл
//Кон Испр 


//Испр СМ
Таб.КонтрагентыРазрез = Ит.Субконто(д).Контрагенты.Контрагент; //Ругается на эту строчку
//Кон Испр

Ит.ВыбратьСубконто(1);
Пока Ит.ПолучитьСубконто(1)=1 Цикл
Если Ит.Субконто(1).ВидКлассификатора<>Перечисление.ВидКлассификатора.Разделы Тогда
Продолжить;
КонецЕсли;
Ит.ВыбратьСубконто(2);
Пока Ит.ПолучитьСубконто(2)=1 Цикл 

Если (i = 1) Тогда

Таб.НоваяСтрока();
Таб.ППП = Ит.Субконто(1).ППП.Код;


Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Открой в отладчике
Установи точку останова на строку
Таб.КонтрагентыРазрез = Ит.Субконто(д).Контрагенты.Контрагент; //Ругается на эту строчку
Через "Вычислить выражение" посмотри, что содержится в Ит.Субконто(д)
Кнопочка Спасибо - слева!

Оффлайн roslakov

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-12-06
  • Сайт: 
  • Профессия: Программист 8.1
Там находится элемент справочника контрагенты

Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
тогда так попробуй
Таб.КонтрагентыРазрез = Ит.Субконто(д);
Кнопочка Спасибо - слева!

Оффлайн roslakov

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-12-06
  • Сайт: 
  • Профессия: Программист 8.1
Сделал так:
 
Таб.КонтрагентыРазрез = Ит.Субконто(д).Наименование;

При продолжении отладки ругается на след. строку:
Не выбран элемент вышестоящей группировки!
         
Ит.ВыбратьСубконто(1);
   

Но выполняется дальше, в таблицу выводит в каждую строку где должно быт наименование контрагента Таб.КонтрагентыРазрез
И при выводе каждой строки отчета выдает ошибку: Поле агрегатного объекта не обнаружено (КонтрагентыРазрез)!


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
47 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 239
  • Точка Скрытых: 0
  • Точка Пользователей: 9
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal