Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 10:03
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Реестр  (Прочитано 3765 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Jalekons

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-09-06
  • Сайт: 
  • Профессия: Ученик 1С
Реестр
« Первое сообщение: 06 Сен 2011, 22:31 »
Добрый день. Помогоите наладить реестр.
В Общем журнале добавил графу Водитель. Сделал быстрый отбор по Водителю. Всё работает.

В Реестре Документов получил отчёт  реестр документов(накладныx) по водителю, но перестал выдовать отчёт реестр по контрагенту, реестр по видам документов, и т.д.

 //Проверка водителя
      Если ВыбВодитель.Выбран() = 1 Тогда
         ХорошийДокумент = 0;
         Если глЕстьРеквизитШапки("Водитель",Док.Вид()) = 1 Тогда
            Если (Док.Водитель = ВыбВодитель) Тогда
               ХорошийДокумент = 1;
            КонецЕсли;             
         КонецЕсли;             
      Если ХорошийДокумент = 0  Тогда
             Продолжить;
         КонецЕсли;
      КонецЕсли;
Выдаёт:
{Отчет.РеестрДокументов.Форма.Модуль(287)}: Значение не представляет агрегатный объект (Выбран)


Так же в реестре выводится столбец с весом по накладной, не могу получить суммарный вес в конце столбца.

   //Таб.ВывестиСекцию("КонецОтчета");
   //глОживить(1);
   
   КолвоСтрок = СуммыПоВалютам.КоличествоСтрок();
   Если КолвоСтрок >= 1 Тогда
      СуммыПоВалютам.ПолучитьСтрокуПоНомеру(1);
      Сумма = СуммыПоВалютам.Сумма;
      Валюта = СуммыПоВалютам.Валюта;
      Итог = ;
      
Помогите разобраться.


Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Re: Реестр
« Ответ #1: 07 Сен 2011, 06:49 »
Если ВыбВодитель.Выбран() = 1 Тогда
попробуй заменить на
Если ВыбВодитель.ПустоеЗначение() = 0 Тогда
Кнопочка Спасибо - слева!

Оффлайн Jalekons

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-09-06
  • Сайт: 
  • Профессия: Ученик 1С
Re: Реестр
« Ответ #2: 07 Сен 2011, 09:51 »
Спасибо, но теперь реестр не выходит и по Водителям :fdbsdfbsd:

{Отчет.РеестрДокументов.Форма.Модуль(349)}: Поле агрегатного объекта не обнаружено (ПустоеЗначение)

Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Re: Реестр
« Ответ #3: 07 Сен 2011, 10:03 »
прицепи отчет как ert
Кнопочка Спасибо - слева!

Оффлайн Jalekons

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-09-06
  • Сайт: 
  • Профессия: Ученик 1С
Re: Реестр
« Ответ #4: 07 Сен 2011, 11:44 »
Прицепил!

Оффлайн Jalekons

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-09-06
  • Сайт: 
  • Профессия: Ученик 1С
Re: Реестр
« Ответ #5: 07 Сен 2011, 15:05 »
Спасибо!!! С реестром  разобрался :zebzdr:. Остался вопрос с общим весом в конце колонке. Как суммировать ячейки? :dfbsdfbsdf:

Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Re: Реестр
« Ответ #6: 07 Сен 2011, 16:15 »
		итог = итог+ИтогВес;
Таб.ВывестиСекцию("Докум");

И где-то в начале процедуры Сформировать()
Итог = 0;
Кнопочка Спасибо - слева!

Оффлайн Jalekons

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-09-06
  • Сайт: 
  • Профессия: Ученик 1С
Re: Реестр
« Ответ #7: 07 Сен 2011, 22:48 »
Всё получилось. Спасибо за помощь.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
BuhRust
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 216
  • Точка Скрытых: 1
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal