Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 09:53
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Вывод данных регистра сведений в форму списка справочника  (Прочитано 8577 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Stoyan

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-09-03
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте, уважаемые специалисты по 1С. Помогите, пожалуйста, разобраться со следующим вопросом. Это - 1С 8.2, конфигурация "УТП". В справочнике есть периодические реквизиты, данные в них добавляются как самим справочником, так и при проведении из документа. Всё нормально работает, даже отображение значения периодического реквизита в форме элемента справочника (запросом из регистра сведений). Но вот с отображением этого реквизита в форме списка этого справочника возникли сложности. Код, я понимаю, совершенно неправильный:

Функция ПриОткрытии()
     ЭлементыФормы.СправочникСписок.Колонки.ЦенаПриходная = ВернутьПриходнуюЦену(СправочникОбъект.Ссылка);
КонецФункции   


Функция ВернутьПриходнуюЦену(Наименование)   
Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
            |   ЦенаПриходнаяСрезПоследних.Цена
            |ИЗ
            |   РегистрСведений.ЦенаПриходная.СрезПоследних(&Дата, Номенклатура = &Номенклатура) КАК ЦенаПриходнаяСрезПоследних";
Запрос.УстановитьПараметр("Дата", КонецДня(ТекущаяДата()));
Запрос.УстановитьПараметр("Номенклатура", Наименование);
ТаблицаРезультата = Запрос.Выполнить().Выгрузить();
Если ТаблицаРезультата.Количество()=0 Тогда
   Возврат 0;   
Иначе
   Возврат ТаблицаРезультата[0].Цена;   
КонецЕсли;
            
КонецФункции



Функция "ПриОткрытии" установлена в событии формы списка справочника "ПриОткрытии". При этом для "СправочникОбъект" отладчик показывает только код одной из записей данных, остальные поля/атрибуты в нём пустые, для "ВерсияДанных" есть фраза "Ошибка чтения значения". Подозреваю, что к моменту вызова "СправочникОбъект" сам справочник ещё не открыт, как его программно открыть - не пойму. Даже если бы нормально выгрузилось содержимое справочника, то надо было бы, конечно же, заполнить каждую строку элемента формы "СправочникСписок", но он не ведёт себя как таблица, и я не соображу, как по-нормальному пробежать его строки в цикле (если в этом вообще есть необходимость). Извините за сумбурность и обилие текста, вопрос вкратце таков: как правильно присвоить некоторым полям формы списка справочника соответствующие данные периодических реквизитов из регистра сведений ?


Оффлайн Stoyan

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-09-03
  • Сайт: 
  • Профессия: Ученик 1С
Похоже, не весь текст отобразился ? У меня после кода есть ещё текст, он виден ?

Оффлайн Stoyan

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-09-03
  • Сайт: 
  • Профессия: Ученик 1С
Странно, в перечне тем есть уже один ответ, а я его не вижу... :-(


Теги:
 

Перенос данных из 1с 82 БП (базовая) в 1с 82 БГУ (базовая)

Автор Владимир87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7430
Последний ответ 06 Дек 2014, 17:40
от дфтын
Поиск по бае данных,(полнотекстовый поиск)

Автор kot_ooРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3881
Последний ответ 19 Май 2014, 15:40
от kot_oo
Как исправить при обновлении ИБ: Ошибка в запросе набора данных по причине: {(58, 2)}: Несовместимые типы "ВЫБОР" <<?>>ВЫБОР

Автор dollРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2111
Последний ответ 01 Янв 2017, 20:27
от Геннадий ОбьГЭС
"Задваивание" данных в отчете

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 7319
Последний ответ 15 Окт 2015, 11:21
от Mari_beginner
Как вызвать "Анализ субконто" из справочника "Контрагенты"

Автор EnigManРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 6486
Последний ответ 06 Фев 2012, 10:46
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
168 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 780
  • Точка Скрытых: 0
  • Точка Пользователей: 12
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal