Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
27 Май 2018, 12:53
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: проверка созданного документа на основании  (Прочитано 3320 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн serq82

  • *
  • Сообщений: 22
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-25
  • Сайт: 
  • Профессия: Бухгалтер
Добрый день!
1С 8.2 Управление Торговлей
Создал документ ЗаданиеНаПроизводство
Создал справочник ВидПрофиля
В документе ЗаказПокупателя добавил кнопку СформироватьЗаданиеНаПроизводство,документы создаются для каждого ВидаПрофиля отдельный документ
вот код:
Процедура СформироватьЗПНажатие(Элемент)
Если Не Проведен Тогда
Предупреждение("Сформировать можно только после его проведения!");
Возврат;
КонецЕсли;
МассивВидовПрофилей = Новый Массив;

Для Каждого СтрокаТЧ Из Товары Цикл
НайденныйВидПрофиля = МассивВидовПрофилей.Найти(СтрокаТЧ.Номенклатура.ВидПрофиля);
Если НайденныйВидПрофиля = Неопределено Тогда
МассивВидовПрофилей.Добавить(СтрокаТЧ.Номенклатура.ВидПрофиля);
КонецЕсли;
КонецЦикла;

Для Каждого ЭлементМассива Из МассивВидовПрофилей Цикл
СоздатьДокументЗаданиеНаПроизводство(ЭлементМассива);
КонецЦикла;
КонецПроцедуры

Процедура СоздатьДокументЗаданиеНаПроизводство(ЭлементМассива)

ЗаданиеНаПроизводство = Документы.ЗаданиеНаПроизводство.СоздатьДокумент();
//ЗаданиеНаПроизводство.Номер  = Номер;
ЗаданиеНаПроизводство.Дата = ТекущаяДата();
ЗаданиеНаПроизводство.ДокументОснование = Ссылка;
ЗаданиеНаПроизводство.ДатаОтгрузки = ДатаОтгрузки;
ЗаданиеНаПроизводство.Контрагент = Контрагент;
//ЗаданиеНаПроизводство.Организация = Организация;
ЗаданиеНаПроизводство.Подразделение = Подразделение;
ЗаданиеНаПроизводство.Комментарий = Комментарий;
Для Каждого СтрокаТЧ Из Товары Цикл

Если СтрокаТЧ.Номенклатура.ВидПрофиля <> ЭлементМассива Тогда
Продолжить;
КонецЕсли;

СтрокиТабл = ЗаданиеНаПроизводство.Товары.Добавить();
СтрокиТабл.Номенклатура = СтрокаТЧ.Номенклатура;
СтрокиТабл.Длина = СтрокаТЧ.Длина;
СтрокиТабл.Ширина = СтрокаТЧ.Ширина;
СтрокиТабл.КоличествоЛистов = СтрокаТЧ.Количество;
СтрокиТабл.Количество = СтрокаТЧ.Количество;

КонецЦикла;

ЗаданиеНаПроизводство.Записать(РежимЗаписиДокумента.Запись);

КонецПроцедуры;
как мне теперь сделать проверку при повторном нажатии кнопки, чтобы не создавались повторные документы для каждого ВидаПрофиля если документ проведен...? и перезаписывало если не проведен и создавал новый если помечен на удаление????


Оффлайн Андрей Федотов

  • ***
  • Сообщений: 231
  • РЕПУТАЦИЯ: 37
  • КПД: 16%
  • Регистрация: 2011-07-07
  • Компания: Future IT Solutions
  • Профессия: Разработчик 1С
Можно запросом вытащить есть ли документ "ЗаданиеНаПроизводство", у которого "ДокументОснование" = Ссылка.
А дальше в запросе вытащить параметры "Проведен", "ПометкаНаУдаление" и всё остальное. Ну и обработать в результате запросе.
С уважением,
Андрей Федотов
Future IT Solutions


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4862
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 17257
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4777
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1202
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 8280
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
alex0402
67 Сообщений
AIFrame AIFrame
56 Сообщений
oleg-x
56 Сообщений
buketov.av buketov.av
47 Сообщений
wise wise
41 Сообщений
ilyay ilyay
39 Сообщений
Анюта17
33 Сообщений
Alter
32 Сообщений
alexandr_ll
30 Сообщений

* Кто онлайн

  • Точка Гостей: 218
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal