Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 00:07
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Вопросик  (Прочитано 2389 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн FRanse

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-09-02
  • Сайт: 
  • Профессия: Ученик 1С
Вопросик
« Первое сообщение: 02 Сен 2011, 11:23 »
Здравствуйте! Есть ли метод добавления колонок к уже сушествуюшему макету? При чем нужное кол-во колонок заранее не известно.


Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Re: Вопросик
« Ответ #1: 02 Сен 2011, 11:27 »
Можно сделать область и ее выводить. Если я правильно понял

Оффлайн kostyas311

  • *
  • Сообщений: 22
  • РЕПУТАЦИЯ: 3
  • КПД: 14%
  • Регистрация: 2011-04-27
  • Сайт: 
  • Профессия: Ученик 1С
Re: Вопросик
« Ответ #2: 02 Сен 2011, 11:29 »
вот пример (на строке) в макете есть область строка, а в цикле она добавляется
Пока Выборка.Следующий() Цикл
//Если (Найти (Выборка.Регистратор, "Объект не найден") = 0 И Найти (Выборка.ХарактеристикаКлюча, "Объект не найден") = 0
//*///*// И Найти (Выборка.Контрагент, "Объект не найден") = 0 ) Тогда
ОбластьСтрока = Макет.ПолучитьОбласть("Строка");
ОбластьСтрока.Параметры.Регистратор = Выборка.Регистратор;
ОбластьСтрока.Параметры.ХарактеристикаКлюча = Выборка.ХарактеристикаКлюча;
ОбластьСтрока.Параметры.Контрагент = Выборка.Контрагент;
Таб.Вывести(ОбластьСтрока);



Количество = Количество + 1;
// КонецЕсли;
КонецЦикла;

Оффлайн kostyas311

  • *
  • Сообщений: 22
  • РЕПУТАЦИЯ: 3
  • КПД: 14%
  • Регистрация: 2011-04-27
  • Сайт: 
  • Профессия: Ученик 1С
Re: Вопросик
« Ответ #3: 02 Сен 2011, 11:30 »
Пока Выборка.Следующий() Цикл
      //Если (Найти (Выборка.Регистратор, "Объект не найден") = 0 И Найти (Выборка.ХарактеристикаКлюча, "Объект не найден") = 0
   //*///*//      И Найти (Выборка.Контрагент, "Объект не найден") = 0 ) Тогда
         ОбластьСтрока = Макет.ПолучитьОбласть("Строка");
         ОбластьСтрока.Параметры.Регистратор = Выборка.Регистратор;
         ОбластьСтрока.Параметры.ХарактеристикаКлюча = Выборка.ХарактеристикаКлюча;
         ОбластьСтрока.Параметры.Контрагент = Выборка.Контрагент;
         Таб.Вывести(ОбластьСтрока);
   
         Количество = Количество + 1;
   //   КонецЕсли;
   КонецЦикла;

Оффлайн FRanse

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-09-02
  • Сайт: 
  • Профессия: Ученик 1С
Re: Вопросик
« Ответ #4: 02 Сен 2011, 11:34 »
не получится т.к таких областей может быть от одной до н. Тоесть у меня есть колонка "прочие" например состояшия из отпускных и премии за год мне нужно вместо вкладки прочие вывести две колонки отпускные и премия за год.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
166 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
36 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 267
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal