Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
25 Июн 2018, 07:19
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Проблемы с обходом табличной части документа  (Прочитано 5224 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн fairei

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-08-30
  • Сайт: 
  • Профессия: Разработчик 1С
начал обучаться по книге радченко, решил добавить свой обработчик на изменение даты:
&НаКлиенте
Процедура ДатаПриИзменении(Элемент)
Если Элементы.ПереченьНоменклатуры.ВыделенныеСтроки.Количество() <> 0 Тогда
Для каждого ТекСтрокаНоменклатура из ПереченьНоменклатуры Цикл
ТекСтрокаНоменклатура.Цена = РаботаСоСправочниками.РозничнаяЦена(Объект.Дата, ТекСтрокаНоменклатура);
РаботаСДокументами.РассчитатьСумму(ТекСтрокаНоменклатура);
КонецЦикла;
КонецЕсли;
КонецПроцедуры
на что говорит: {Документ.ОказаниеУслуги.Форма.ФормаДокумента.Форма(24,40)}: Переменная не определена (ПереченьНоменклатуры)
посмотрел на форуме, вроде так и пишет народ...
исправляю вот так:
Процедура ДатаПриИзменении(Элемент)
Если Элементы.ПереченьНоменклатуры.ВыделенныеСтроки.Количество() <> 0 Тогда
Для каждого ТекСтрокаНоменклатура из Элементы.ПереченьНоменклатуры Цикл
ТекСтрокаНоменклатура.Цена = РаботаСоСправочниками.РозничнаяЦена(Объект.Дата, ТекСтрокаНоменклатура);
РаботаСДокументами.РассчитатьСумму(ТекСтрокаНоменклатура);
КонецЦикла;
КонецЕсли;
КонецПроцедуры
{Документ.ОказаниеУслуги.Форма.ФормаДокумента.Форма(24)}: Итератор для значения не определен
      Для каждого ТекСтрокаНоменклатура из Элементы.ПереченьНоменклатуры Цикл
что не так?
и еще вопрос, каким образом проверять наличие информации в табличной части документа (ПереченьНоменклатуры), я это делаю так:
...Если Элементы.ПереченьНоменклатуры.ВыделенныеСтроки.Количество() <> 0 Тогда...
но думаю есть свойство, типа Элементы.ПереченьНоменклатуры.пусто = Истина???
Спасибо!


Оффлайн fairei

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-08-30
  • Сайт: 
  • Профессия: Разработчик 1С
начал обучаться по книге радченко, решил добавить свой обработчик на изменение даты:

&НаКлиенте
Процедура ДатаПриИзменении(Элемент)
 Если Элементы.ПереченьНоменклатуры.ВыделенныеСтроки.Количество() <> 0 Тогда
  Для каждого ТекСтрокаНоменклатура из ПереченьНоменклатуры Цикл
   ТекСтрокаНоменклатура.Цена = РаботаСоСправочниками.РозничнаяЦена(Объект.Дата, ТекСтрокаНоменклатура);
   РаботаСДокументами.РассчитатьСумму(ТекСтрокаНоменклатура);
  КонецЦикла;
 КонецЕсли;
на что говорит: {Документ.ОказаниеУслуги.Форма.ФормаДокумента.Форма(24,40)}: Переменная не определена (ПереченьНоменклатуры)
посмотрел на форуме, вроде так и пишет народ...
исправляю вот так:
...Для каждого ТекСтрокаНоменклатура из Элементы.ПереченьНоменклатуры Цикл...
что не так?
и еще вопрос, каким образом проверять наличие информации в табличной части документа (ПереченьНоменклатуры), я это делаю так:
...Если Элементы.ПереченьНоменклатуры.ВыделенныеСтроки.Количество() <> 0 Тогда...
но думаю есть свойство, типа Элементы.ПереченьНоменклатуры.пусто = Истина???
Спасибо!

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1311
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
А так?
 Для каждого ТекСтрокаНоменклатура из Обьект.ПереченьНоменклатуры Цикл

Оффлайн fairei

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-08-30
  • Сайт: 
  • Профессия: Разработчик 1С
А так?
 Для каждого ТекСтрокаНоменклатура из Обьект.ПереченьНоменклатуры Цикл


так тоже не катит: {Документ.ОказаниеУслуги.Форма.ФормаДокумента.Форма(25)}: Ошибка при вызове метода контекста (РозничнаяЦена): Ошибка при вызове серверного метода.
            ТекСтрокаНоменклатура.Цена = РаботаСоСправочниками.РозничнаяЦена(Объект.Дата, ТекСтрокаНоменклатура);
несовпадение типов

вот процедура:
Процедура ДатаПриИзменении(Элемент)
   Если Элементы.ПереченьНоменклатуры.ВыделенныеСтроки.Количество() <> 0 Тогда
      Для каждого ТекСтрокаНоменклатура из Объект.ПереченьНоменклатуры Цикл
            ТекСтрокаНоменклатура.Цена = РаботаСоСправочниками.РозничнаяЦена(Объект.Дата, ТекСтрокаНоменклатура);
            РаботаСДокументами.РассчитатьСумму(ТекСтрокаНоменклатура);
      КонецЦикла;
   КонецЕсли;
КонецПроцедуры

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1311
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Ну в отладчике посмотри тип ТекСтрокаНоменклатура. А точно на клиенте выполнять нада?

Оффлайн ivanov660

  • *
  • Сообщений: 18
  • РЕПУТАЦИЯ: 1
  • КПД: 6%
  • Регистрация: 2011-09-05
  • Компания: Орион XL
  • Профессия: Программист 1С
Ну в отладчике посмотри тип ТекСтрокаНоменклатура. А точно на клиенте выполнять нада?
А в настройках модуля стоит разрешение на вызов в клиентском приложении?
+
Разделяйте понятия в НаКлиенте и НаСервере, т.е. надо разделять код процедуры на серверные и клиентские (т.к. на управляемом клиенте маленький перечень используемых функций).


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4893
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 8314
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5628
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 10435
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Фамилия руководителя в печатных формах документа "Акт сверки", "Акт об оказании"

Автор MKozzlikРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 7894
Последний ответ 03 Фев 2012, 17:27
от Dinah

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

AIFrame AIFrame
125 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
116 Сообщений
alexandr_ll
65 Сообщений
pavl_vs
40 Сообщений
alex0402
28 Сообщений
buketov.av buketov.av
24 Сообщений
magnifico61
21 Сообщений
wise wise
16 Сообщений
ilyay ilyay
15 Сообщений
mixei
14 Сообщений

* Кто онлайн

  • Точка Гостей: 310
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal