Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 09:27
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Переменная не определена (ПричинаУвол)  (Прочитано 5923 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Oasis

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-08-30
  • Сайт: 
  • Профессия: Ученик 1С
Платформа 7.7 (7.70.027)

Текст программы:
Процедура Очистить()
    ВыбратьСтроки();
    Если ПолучитьСтроку()=1 Тогда
        УдалитьСтроку();
КонецЕсли;
Пока НомерСтроки<>0 Цикл
УдалитьСтроку();
КонецЦикла;
КонецПроцедуры


Процедура Заполнить()
    Очистить();
    СпрСотрудники=СоздатьОбъект("Справочник.Сотрудники");
    СпрСотрудники.ВыбратьЭлементы();
    Пока СпрСотрудники.ПолучитьЭлемент()=1 Цикл
        Если СпрСотрудники.Состояние<>Перечисление.ПринятУволен.Уволен Тогда
            НоваяСтрока();
            Сотрудник=СпрСотрудники.ТекущийЭлемент();
            Подразделение=СпрСотрудники.Подразделение.Получить(РабочаяДата());
            ДатаУвольнения=ДатаУвол;
            ПричинаУвольнения=ПричинаУвол;
КонецЕсли;
КонецЦикла;
КонецПроцедуры

Пишет ошибку:

ПричинаУвольнения=ПричинаУвол<<?>>;
{Документ.ПриказОбУвольнении.Форма.Модуль(23)}: Переменная не определена (ПричинаУвол)

Что не правильно?



Оффлайн Lexus77

  • **
  • Сообщений: 80
  • РЕПУТАЦИЯ: 9
  • КПД: 11%
  • Регистрация: 2011-06-20
  • Сайт: 
  • Профессия: Программист 1С
ПричинаУвол что это такое? Реквизит формы или что? Откуда он берется?

Оффлайн AFZ

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 5
  • КПД: 42%
  • Регистрация: 2011-07-19
  • Сайт: 
  • Профессия: Программист 1С
После
СпрСотрудники=СоздатьОбъект("Справочник.Сотрудники");
надо добавить
ПричинаУвол=ПолучитьПустоеЗначение();

Оффлайн Oasis

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-08-30
  • Сайт: 
  • Профессия: Ученик 1С
После
СпрСотрудники=СоздатьОбъект("Справочник.Сотрудники");
надо добавить
ПричинаУвол=ПолучитьПустоеЗначение();

Большое спасибо. Заработало.

P.S. вроде делаешь все по методичке для начинающих и такие ошибки раз за разом.  :wacko:
Вот сейчас тоже сижу голову ломаю над
"Объект заблокирован: Иванов И.С."
...  :dfbbdrfb:

Оффлайн AFZ

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 5
  • КПД: 42%
  • Регистрация: 2011-07-19
  • Сайт: 
  • Профессия: Программист 1С
В сетевой 1С другой пользователь открыл на экране форму элемента сотрудника "Иванов".
Вы тоже пытаетесь открыть, но не можете.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
177 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
alex0402
44 Сообщений
AIFrame
44 Сообщений
andron81_81
38 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal