Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 01:01
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: ЗиК 7.7 - сумма без копеек  (Прочитано 4238 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Neksion

  • *
  • Сообщений: 18
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-28
  • Сайт: 
  • Профессия: Программист 8.1
ЗиК 7.7
Подскажите пожалуйста как сделать чтоб в отчете сумма формировалась с копейками.
В запрсе есть строки:
        |Период с НачДата по КонДата;
        |Объект = ЖурналРасчетов.Зарплата.Объект;
        |ТекущаяЗапись = ЖурналРасчетов.Зарплата.ТекущаяЗапись;
        |Функция Начислено = Сумма(ПолучитьСуммуПоИсточнику(ТекущаяЗапись));

Функция ПолучитьСуммуПоИсточнику(ЗаписьИзЖурнала)
   
   ТаблицаРаспределения = СоздатьОбъект("ТаблицаЗначений");   
   ТаблицаРаспределения.НоваяКолонка("Шаблон","Справочник.ШаблоныПроводок",,,,,,);
   ТаблицаРаспределения.НоваяКолонка("Сумма","Число",15,,,);
   
   глПолучитьРаспределениеРезультата(ЗаписьИзЖурнала,ТаблицаРаспределения,,,,,,,1);
   Сумма = 0;
   ТаблицаРаспределения.ВыбратьСтроки();
   Пока ТаблицаРаспределения.ПолучитьСтроку() = 1 Цикл
      Если ТаблицаРаспределения.Шаблон.СчетКредита.ИсточникФинансирования = ИФ Тогда
         Сумма = Сумма + ТаблицаРаспределения.Сумма;
      КонецЕсли;
   КонецЦикла;
   
   Возврат Сумма;
   
КонецФункции // ПолучитьСуммуПоИсточнику

Я так понимаю что сумма без копеек уже получается при выполнении процедурки глПолучитьРаспределениеРезультата.


Оффлайн ОльгаН

  • **
  • Сообщений: 90
  • РЕПУТАЦИЯ: 14
  • КПД: 16%
  • Регистрация: 2011-07-11
  • Сайт: 
  • Профессия: Ученик 1С
А не указать ли Вам в формате новой колонки точность? ТаблицаРаспределения.НоваяКолонка("Сумма","Число",15,2,,);

Оффлайн Neksion

  • *
  • Сообщений: 18
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-28
  • Сайт: 
  • Профессия: Программист 8.1
Это не помогает), пробовал

Оффлайн ОльгаН

  • **
  • Сообщений: 90
  • РЕПУТАЦИЯ: 14
  • КПД: 16%
  • Регистрация: 2011-07-11
  • Сайт: 
  • Профессия: Ученик 1С
Посмотрите ТаблицуРаспределения после при выходе из глПолучитьРаспределениеРезультата: ТаблицаРаспределения.ВыбратьСтроку(); с тем,чтобы убедиться в Вашем предположении.

Оффлайн Neksion

  • *
  • Сообщений: 18
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-28
  • Сайт: 
  • Профессия: Программист 8.1
в процедуре все правильно с копейками, видимо при суммировании в запросе округляется

Оффлайн ОльгаН

  • **
  • Сообщений: 90
  • РЕПУТАЦИЯ: 14
  • КПД: 16%
  • Регистрация: 2011-07-11
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день. Думаю, что Вы уже справились с проблемкой. На всякий случай, мое решение:    
ТекстЗапроса =
   "//{{ЗАПРОС(Сформировать)
   |Период с НачДата по КонДата;
   |Объект = ЖурналРасчетов.Зарплата.Объект;
   |ТекущаяЗапись = ЖурналРасчетов.Зарплата.ТекущаяЗапись;
   |Группировка ТекущаяЗапись;
   
   |"//}}ЗАПРОС
   ;
   // Если ошибка в запросе, то выход из процедуры
   Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
      Возврат;
   КонецЕсли;
 

   Начислено = 0;
   
   Пока Запрос.Группировка(1)=1 цикл
   Начислено = Начислено+ПолучитьСуммуПоИсточнику(Запрос.ТекущаяЗапись);   
      
   КонецЦикла;   
   

Оффлайн Neksion

  • *
  • Сообщений: 18
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-28
  • Сайт: 
  • Профессия: Программист 8.1
Спасибо большое за ответы, проблему решил.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
170 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 222
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal