Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 19:37
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как сделать цвет области по условию  (Прочитано 1211 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн gorelchik

  • **
  • Сообщений: 76
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-06-30
  • Сайт: 
  • Профессия: Программист 7.7
Помогите пжлст, где поставить условие чтобы область строка в цикле была другого цвета в зависмости от условия. вот мой код
Заявка.ВыбратьДокументы(НачДата,КонДата);   
   ИтогР=0;
   Пока Заявка.ПолучитьДокумент()=1 Цикл
      Номер = 0;
      Если ПустоеЗначение(Заявка.НомерСпецификации) = 0 тогда
      Таб.ВывестиСекцию("Строка"); // вот эта строка должна менять цвет
      
      Если ПустоеЗначение(СокрЛП(Заявка.ПутьКФайлуСпец)) = 0 тогда
   
      Таб.Область(Обл).ЦветФона(0,255,0); //какое значение дать переменной обл, чтобы она прибовляла строки постоянно

      КонецЕсли;
      
      Заявка.ВыбратьСтроки();
      Пока Заявка.ПолучитьСтроку() = 1 Цикл
         Реализация.ВыбратьДокументы(НачДата,КонДата);
         Пока Реализация.ПолучитьДокумент() = 1 Цикл
            Реализация.ВыбратьСтроки();
            Пока Реализация.ПолучитьСтроку() = 1 Цикл
               Если (СокрЛП(Заявка.НомерСпецификации) = СокрЛП(Реализация.Спецификация)) и (СокрЛП(Заявка.Контрагент) = СокрЛП(Реализация.Контрагент)) и (СокрЛП(Заявка.Товар) = СокрЛП(Реализация.Товар)) тогда
               ИтогР = ИтогР + Реализация.Количество;
               КонецЕсли;
            КонецЦикла;               
         КонецЦикла;
         
         Номер=Номер+1;
         Таб.ВывестиСекцию("Строка1");          
         ИтогР=0;              
      КонецЦикла;       
      КонецЕсли;
   КонецЦикла;     


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
141 Сообщений
AIFrame
71 Сообщений
ilyay ilyay
65 Сообщений
alex0402
52 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
BuhRust
31 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 358
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal