Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 05:41
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Импорт с Excel в справочник 1С  (Прочитано 3515 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн voyyager

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-08-25
  • Сайт: 
  • Профессия: Ученик 1С

День Добрый! Имеется процедура для импорта с экселя записей в справочник 1С в соответствующие папки. Имя родителя берется с 3-го столбца файла экселя. Беда в том, что когда импортируешь, то нечетные строки записываются куда надо и в разные папки, а четные в корень справочника. Понять не могу в чем причина...

Процедура ИмпортИзЭкселяСРодителем()  
    НачатьТранзакцию();
xl=СоздатьОбъект("Excel.Application");
    rows=xl.ActiveSheet.UsedRange.Rows.Count;
    спр=СоздатьОбъект("Справочник.Клиенты");
    Для row = 1 По rows Цикл
        имя=СокрЛП(xl.Cells(row,1).Value);
фио=СокрЛП(xl.Cells(row,2).Value);
родитель=СокрЛП(xl.Cells(row,3).Value);
Сообщить(родитель);
Состояние(""+row+"/"+rows+"  "+имя);
        Если имя="" Тогда
            Продолжить;
КонецЕсли;
        Если спр.НайтиПоНаименованию(имя, 0, 1)=0 Тогда
спр.НайтиПоНаименованию(родитель);
родитель = спр.ТекущийЭлемент();
спр.ИспользоватьРодителя(родитель);
                        спр.Новый();
                        спр.Наименование=имя;
спр.УстановитьАтрибут("ФИО",фио);
спр.УстановитьАтрибут("Адрес",род);
                        спр.Записать();
КонецЕсли;    
    КонецЦикла;
    ЗафиксироватьТранзакцию();
Конецпроцедуры

Последний раз редактировалось: prog1c7.7; 25 Авг 2011, 15:40


Оффлайн AFZ

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 5
  • КПД: 42%
  • Регистрация: 2011-07-19
  • Сайт: 
  • Профессия: Программист 1С
спр.НайтиПоНаименованию(родитель);
надо исправить на
спр.НайтиПоНаименованию(родитель,0);

Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
А как загрузить остатки в регистор для номенклатуры по торг.точкам из XLS
 
Помогли, отблагодари!


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
175 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
alex0402
44 Сообщений
AIFrame
39 Сообщений
andron81_81
38 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 282
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal