Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
22 Май 2018, 07:27
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: не выпадает список выбора  (Прочитано 5563 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн kivixi

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-25
  • Сайт: 
  • Профессия: Бухгалтер
Процедура ЗагрузитьИзТабличногоДокумента(Кнопка)   и так почти по всем документам , подскажите чего в модуле подправить


Справочник.Контрагенты.Форма.ФормаСписка Не обнаружено ссылок на процедуру: "ЗагрузитьИзТабличногоДокумента"


модуль

// Процедура - обработчик нажатия кнопки "ЗагрузитьИзФайла"
// командной панели формы.
//
Процедура ЗагрузитьИзТабличногоДокумента(Кнопка)
   ОтраслевоеРешение.ЗагрузитьСправочникИзТабличногоДокумента(Справочники.Контрагенты.ПустаяСсылка(), "Контрагенты", ЭтаФорма);
КонецПроцедуры

// Процедура - обработчик события "ПередОткрытием" формы.
//
Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
   ОтраслевоеРешение.СформироватьКнопкуЗагрузкиСправочникаИзФайла(ЭлементыФормы.ДействияФормы.Кнопки.Подменю);   
КонецПроцедуры



Оффлайн Nail2010

  • ****
  • Сообщений: 325
  • РЕПУТАЦИЯ: 18
  • КПД: 6%
  • Регистрация: 2010-10-27
  • Сайт: 
Чувак, код тут не при делах - открой свойства реквизита, где должен у тебя выпадать список и галочкой отметь БЫСТРЫЙ ВЫБОР и ВЫБОР ИЗ СПИСКА.

Оффлайн kivixi

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-25
  • Сайт: 
  • Профессия: Бухгалтер
Nail2010, не помагает вылазит при проверке конфы такое сообщение : Справочник.Контрагенты.Форма.ФормаСписка Не обнаружено ссылок на процедуру: "ЗагрузитьИзТабличногоДокумента"

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1310
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Цитировать
// Процедура - обработчик нажатия кнопки "ЗагрузитьИзФайла"
А процедура как обработчик кнопки указана?

Оффлайн kivixi

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-25
  • Сайт: 
  • Профессия: Бухгалтер
has, да обработчик кнопки указан

Оффлайн kivixi

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-25
  • Сайт: 
  • Профессия: Бухгалтер
подскажите как это дело исправить две процедуры не работают косячные

// Процедура - обработчик нажатия кнопки "ЗагрузитьИзФайла"
// командной панели формы.
//

Процедура ЗагрузитьИзТабличногоДокумента(Кнопка)
   ОтраслевоеРешение.ЗагрузитьСправочникИзТабличногоДокумента(Справочники.Контрагенты.ПустаяСсылка(), "Контрагенты", ЭтаФорма);
КонецПроцедуры


// Процедура - обработчик события "ПередОткрытием" формы.
//

Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
   ОтраслевоеРешение.СформироватьКнопкуЗагрузкиСправочникаИзФайла(ЭлементыФормы.ДействияФормы.Кнопки.Подменю);   
КонецПроцедуры

Оффлайн Nail2010

  • ****
  • Сообщений: 325
  • РЕПУТАЦИЯ: 18
  • КПД: 6%
  • Регистрация: 2010-10-27
  • Сайт: 
ЗагрузитьИзтабличногоДокумента и ЗагрузитьСправочникИзТабличногоДокумента - это 2 разныхпроцедуры. или все-таки ты ошибку в названии допустил? У тебя код ошибки явно показывает - нет ссылок на указанную процедуру. На какую из 2-х?


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
147 Сообщений
oleg-x
66 Сообщений
alex0402
63 Сообщений
AIFrame AIFrame
52 Сообщений
wise wise
37 Сообщений
KOI8-R
34 Сообщений
buketov.av buketov.av
34 Сообщений
Alter
25 Сообщений
BuhRust
20 Сообщений
trialex3
20 Сообщений

* Кто онлайн

  • Точка Гостей: 351
  • Точка Скрытых: 0
  • Точка Пользователей: 14
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal