Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
21 Июн 2018, 19:16
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Не выбирается элемент в форме выбора  (Прочитано 15302 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн cannabis_86

  • ***
  • Сообщений: 168
  • РЕПУТАЦИЯ: 19
  • КПД: 11%
  • Регистрация: 2010-08-26
  • Сайт: 
Пишу свою конфу в 1с 8.2 управляемое приложение. В документ есть ссылка не спр.сотрудники. Я изменил процедуру выбора, т.е. мне нужно было чтобы открывался спр с неким отбором. Вроде это получилось. Но вот как заставить передать выбранную позицию в форму документа? Код Следующий
&НаКлиенте
Процедура СотрудникНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
СтандартнаяОбработка = Ложь;
СписокЭлементов = Отобрать();

ФормаВыбора = ПолучитьФорму("Справочник.Сотрудники.ФормаВыбора");
Если ЗначениеЗаполнено(СписокЭлементов) Тогда
    ЭлементОтбора = ФормаВыбора.Список.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
    ЭлементОтбора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("Наименование");
    ЭлементОтбора.ВидСравнения = ВидСравненияКомпоновкиДанных.ВСписке;
    ЭлементОтбора.Использование = Истина;
    ЭлементОтбора.РежимОтображения = РежимОтображенияЭлементаНастройкиКомпоновкиДанных.Недоступный;
    ЭлементОтбора.ПравоеЗначение = СписокЭлементов;
ФормаВыбора.Открыть();
Иначе
Сообщить("Нет устроенных сотрудников!!!");
КонецЕсли;


КонецПроцедуры

&НаСервере
Функция Отобрать()
Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
               | РаботникиОрганизацииСрезПоследних.Сотрудник.Наименование КАК Сотрудник
               |ИЗ
               | РегистрСведений.РаботникиОрганизации.СрезПоследних КАК РаботникиОрганизацииСрезПоследних
               |ГДЕ
               | РаботникиОрганизацииСрезПоследних.ПричинаИзмененияСосотояния <> &ПричинаИзмененияСосотояния";

Запрос.УстановитьПараметр("ПричинаИзмененияСосотояния", Перечисления.ПричиныИзмененияСостояния.Увольнение);
Выборка = Запрос.Выполнить().Выбрать();

СписокЭлементов = Новый СписокЗначений;
Пока Выборка.Следующий() Цикл
СписокЭлементов.Добавить(СокрЛП(Выборка.Сотрудник));
КонецЦикла;
Возврат СписокЭлементов;

КонецФункции



Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1311
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
В форме документа ОбработкаВыбора, в форме справочника ОповеститьОВыборе. Как-то так.

Оффлайн cannabis_86

  • ***
  • Сообщений: 168
  • РЕПУТАЦИЯ: 19
  • КПД: 11%
  • Регистрация: 2010-08-26
  • Сайт: 
В форме документа ОбработкаВыбора, в форме справочника ОповеститьОВыборе. Как-то так.
Спасибо большое, нужно было добавить в форму выбора:
&НаКлиенте
Процедура ОбработкаВыбора(ВыбранноеЗначение, ИсточникВыбора)
ОповеститьОВыборе(ВыбранноеЗначение);
КонецПроцедуры

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2861
  • РЕПУТАЦИЯ: 548
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
А разе так нельзя?
МойСотрудник = ФормаВыбора.Открыть();
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2861
  • РЕПУТАЦИЯ: 548
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
До этого написав "ФормаВыбора.РежимВыбора = Истина;"
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 

Группа "СписокКомпоновщикНастроекПользовательскиеНастройки" в форме "Перечисления"

Автор Азамат ХубиевРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2189
Последний ответ 12 Ноя 2016, 18:08
от Азамат Хубиев
Изменение цвета при подборе сотрудника в форме списка справочника "Сотрудники организации" для документа "Зарплата к выплате организаций" ЗУП 2.5

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 552
Последний ответ 12 Окт 2017, 14:02
от wise
Как настроить отображение на форме "группа плательщика единого налога" при выборе системы налогообложения "Единый налог"?

Автор Nicolayci91Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2583
Последний ответ 17 Авг 2015, 07:48
от cska-fanat-kz
Добавление строки и заполнение строки в ТЗ на форме

Автор Св ЧРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 799
Последний ответ 25 Сен 2017, 09:00
от Св Ч
Ребята, срочно нужна помощь. Какую процедуру нужно написать в форме справочника, чтобы таблица заполнялась данными из другого справочника?

Автор Олька БякинаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 3191
Последний ответ 27 Май 2016, 15:19
от Олька Бякина

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
138 Сообщений
AIFrame AIFrame
133 Сообщений
alexandr_ll
65 Сообщений
pavl_vs
51 Сообщений
alex0402
44 Сообщений
buketov.av buketov.av
37 Сообщений
ilyay ilyay
36 Сообщений
trialex3
22 Сообщений
wise wise
22 Сообщений
magnifico61
21 Сообщений

* Кто онлайн

  • Точка Гостей: 296
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal