Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 23:49
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: торг-12 нужна помощь  (Прочитано 3341 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн qweasd

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 1
  • КПД: 8%
  • Регистрация: 2011-08-19
  • Сайт: 
  • Профессия: Программист 8.1
помоги пожал разобраться, есть документ возврат от поставщика, ее необходимо распечатать как ТОРГ-12, но при открытии много полей не отпределяются,пишутся в виде кода, открыла форму возврата от поставщика в конфигураторе, однако таблицы там не обнаружила,  печатная форма торг -12 из prnForms отличается от того что выводит на печать, как найти форму на которую ссылается данный документ ,привожу часть  кода

Процедура ПоКнопкеПечать(СразуНаПринтер = 0,КолЭкз = 1)
   
   // проверим полномочия печати непроведенных документов
   Если Проведен() = 0 Тогда
      Если глПолучитьПолномочие("РазрешитьПечатьНепроведенныхДокументов") = 0 Тогда
         Предупреждение("Недостаточно полномочий для печати непроведенного документа!", 60);
         Возврат;
      КонецЕсли;
   КонецЕсли;

   Если  ПустоеЗначение(НомерТекущейФормы) = 1  Тогда
      НомерТекущейФормы = 1;
      Форма.кнПечать.Заголовок(ТаблицаПечФорм.ПолучитьЗначение(НомерТекущейФормы, "Кнопка"));
   КонецЕсли;
   
   Если НомерТекущейФормы = 1  Тогда
      Печать(СразуНаПринтер, КолЭкз);
   Иначе
      Параметры = СоздатьОбъект("СписокЗначений");
      Параметры.ДобавитьЗначение(глВзятьКонтекст(Контекст), "Контекст");
      Параметры.ДобавитьЗначение(СразуНаПринтер, "Устройство");
      Параметры.ДобавитьЗначение(КолЭкз, "КоличествоКопий");
      
      ОткрытьФорму("Отчет", Параметры, глКаталогПечФорм+ТаблицаПечФорм.ПолучитьЗначение(НомерТекущейФормы,"Файл"));
   КонецЕсли;
   
КонецПроцедуры // ПоКнопкеПечать()



буду благодарна ,конфиг комплекс 7.7


Оффлайн prog1c7.7

  • Модератор
  • *****
  • Сообщений: 784
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С

Оффлайн qweasd

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 1
  • КПД: 8%
  • Регистрация: 2011-08-19
  • Сайт: 
  • Профессия: Программист 8.1
спасибо большое

Оффлайн qweasd

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 1
  • КПД: 8%
  • Регистрация: 2011-08-19
  • Сайт: 
  • Профессия: Программист 8.1
а как можно там поменять поля чтобы в др документе ничего не испортить, ведь если я изменю что то ,в другом документе где работало,работать перестанет

Оффлайн prog1c7.7

  • Модератор
  • *****
  • Сообщений: 784
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С
создать условие в документе и добавить измененную
 ячейку в таб форму


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
166 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
36 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
28 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 255
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal