Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 08:27
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Табличная часть формы  (Прочитано 9292 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн cannabis_86

  • ***
  • Сообщений: 168
  • РЕПУТАЦИЯ: 19
  • КПД: 11%
  • Регистрация: 2010-08-26
  • Сайт: 
Здравствуйте, пишу свою конфу на 1с 8.2(упр прил). Создал документ у которого есть табличная часть. Нужно перебрать все колонки этой табл части и выставить их заголовки в соответствии от неких условий. В толстом клиенте видел такое:
    
    Для ДеньМесяца = 1 по День(КонецМесяца(Дата(Элементы.Дата.ТекстРедактирования))) Цикл
        Колонка = ЭлементыФормы.Сотрудники.Колонки["Дата"+Строка(ДеньМесяца)];
    КонецЦикла;

У меня ругается на ЭлементыФормы. Я как понял такого объекта в упр прил нет. Пробовал использовать просто "Элементы". Так у него нет св-ва "Колонки". Как быть в данной ситуации, что использовать? Мб забить на тонкий клиент и делать все в толстом, если такого функционала тонкий клиент не поддерживает?


Оффлайн Archanurik

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-08-19
  • Сайт: 
  • Профессия: Ученик 1С
Попробуйте использовать функцию или процедуру. Напишите это в модуле, у которого установлены флажки в свойствах "Сервер" и "Вызов Сервера".

Оффлайн cannabis_86

  • ***
  • Сообщений: 168
  • РЕПУТАЦИЯ: 19
  • КПД: 11%
  • Регистрация: 2010-08-26
  • Сайт: 
Нету все равно ее. Пробовал и там и там.

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Для каждого х из Объект.Сотрудники.Колонки Цикл
Сообщить(х.Имя);
КонецЦикла;
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн cannabis_86

  • ***
  • Сообщений: 168
  • РЕПУТАЦИЯ: 19
  • КПД: 11%
  • Регистрация: 2010-08-26
  • Сайт: 
Для каждого х из Объект.Сотрудники.Колонки Цикл
Сообщить(х.Имя);
КонецЦикла;
А как мне здесь изменять заголовок элемента формы(таблица)?? Имена колонок я не хочу менять, нужно изменить только заголовки колонок.

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Элементы.ТЗИмяколонки.Заголовок = "Заголовок"; //Вот так
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Где ТЗ- имя табличной части на форм, а Имяколонки- колонка которой меняем заголовок
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн cannabis_86

  • ***
  • Сообщений: 168
  • РЕПУТАЦИЯ: 19
  • КПД: 11%
  • Регистрация: 2010-08-26
  • Сайт: 
Ну тогда в данном случае не будет возможность перебора элемента в цикле. Придется явно указывать имена колонок и задавать им значения. Что выглядит не очень рационально. Но пока как я понял это единственный способ.

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Почему? Я не понимаю тебя...
ИмяКолонки = Элементы.Реквизит1.Имя + Колонка;
Элементы[ИмяКолонки].Заголовок = "БлаБлаБла";
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
ИмяКолонки = Элементы.Реквизит1.Имя + Колонка;
Элементы[ИмяКолонки].Заголовок = "БлаБлаБла";
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 

Не работает метод Сдвинуть() по отношению к программно добавляемой колонке1С:Предприятие 8.3 (8.3.10.2561) Управление производственным предприятием, редакция 1.4 Приветствую, я добавляю программно свою колонку в методе ПриОткрытии() модуля формы, вот так

Автор InsiderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 302
Последний ответ 21 Сен 2017, 10:33
от Insider
Редактирование формы "Настройки пользователя".

Автор t955938Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4829
Последний ответ 03 Авг 2011, 11:45
от t955938
получаю значение реквизита формы, дает значение 0

Автор mikel10Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3423
Последний ответ 12 Июл 2013, 15:35
от mikel10
Как обратиться к функции модуля формы из модуля Менеджера?

Автор TreeDogNightРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 5010
Последний ответ 10 Июл 2014, 14:05
от cska-fanat-kz
Настройка формы "Заполнение товаров"

Автор ЖаннаРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 594
Последний ответ 10 Мар 2017, 21:00
от Жанна

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
135 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
63 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 405
  • Точка Скрытых: 0
  • Точка Пользователей: 12
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal