Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 13:45
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Подскажите, что делать дальше? Загрузка данных в документ  (Прочитано 2755 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн delo_iris

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-11-30
  • Сайт: 
  • Профессия: Ученик 1С
Из формы Обработки нужно загрузить данные в Документ. В форме Обработки есть дерево значений с данными (ДеревоЗн). Из этого ДереваЗн нужно загрузить данные в документ ЗаказКлиента. ДеревоЗн состоит из двух колонок Имя и Значение (строка).

Сначала открываю новый ЗаказКлиента по кнопке Загрузить вызываю обработку ЧтениеИзXML и из формы обработки по кнопке ЗагрузитьВДокумент нужно загрузить данные из формы обработки в документ.

Подскажите правильно ли я делаю.

В форме Обработки ЧтениеИзXML:

&НаКлиенте
Процедура ЗагрузитьВДокумент(Команда)

Закрыть(ЗагрузитьДанныеВДокумент());

КонецПроцедуры

&НаСервере
Функция ЗагрузитьДанныеВДокумент()

Дерево = ДанныеФормыВЗначение(ДеревоЗн, Тип("ДеревоЗначений"));

ДанныеЗаполнения = Дерево.Строки;
ДанныеЗаполнения = Новый Структура;

ЗначениеВДанныеФормы(Дерево, ДеревоЗн);

Возврат ДанныеЗаполнения;

КонецФункции

В форме Документа ЗаказКлиенту:

&НаКлиенте
Процедура Загрузить(Команда)

РезультатОткрытия = ОткрытьФормуМодально("Обработка.ЧтениеИзXML.Форма.Форма", , ЭтаФорма);

КонецПроцедуры


А вот что делать дальше? Как заполнить документ данными?


Оффлайн delo_iris

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-11-30
  • Сайт: 
  • Профессия: Ученик 1С
Что-то с кодом не то.

В модуле формы Обработки:

&НаКлиенте
Процедура ЗагрузитьВДокумент(Команда)

   Закрыть(ЗагрузитьДанныеВДокумент());

КонецПроцедуры

&НаСервере
Функция ЗагрузитьДанныеВДокумент()
   
   Дерево = ДанныеФормыВЗначение(ДеревоЗн, Тип("ДеревоЗначений"));
   
   ДанныеЗаполнения = Дерево.Строки;
   ДанныеЗаполнения = Новый Структура;

   ЗначениеВДанныеФормы(Дерево, ДеревоЗн);
   
   Возврат ДанныеЗаполнения;
   
КонецФункции



В модуле формы Документа:

&НаКлиенте
Процедура Загрузить(Команда)
   
   РезультатОткрытия = ОткрытьФормуМодально("Обработка.ЧтениеИзXML.Форма.Форма", , ЭтаФорма);
      
КонецПроцедуры

Оффлайн delo_iris

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-11-30
  • Сайт: 
  • Профессия: Ученик 1С
В модуле формы обработки изменила:
&НаКлиенте
Процедура ЗагрузитьВДокумент(Команда)

Закрыть(ДеревоЗн);

КонецПроцедуры

&НаСервере
Процедура ЗагрузитьДанныеВДокумент()

Дерево = ДанныеФормыВЗначение(ДеревоЗн, Тип("ДеревоЗначений"));

Дерево.Строки.Очистить();

ЗначениеВДанныеФормы(Дерево, ДеревоЗн);

КонецПроцедуры
В модуле формы документа:
&НаКлиенте
Процедура Загрузить(Команда)

    //ДанныеФормыДерево
РезультатОткрытия = ОткрытьФормуМодально("Обработка.ЧтениеИзXML.Форма.Форма", , ЭтаФорма);

КонецПроцедуры
В РезультатеОткрытия передаются данные моего Дерева. А вот как эти данные загрузить в документ? И как перобразовать к нужному типу?



Теги:
 

Перенос данных из 1с 82 БП (базовая) в 1с 82 БГУ (базовая)

Автор Владимир87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7431
Последний ответ 06 Дек 2014, 17:40
от дфтын
Поиск по бае данных,(полнотекстовый поиск)

Автор kot_ooРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3881
Последний ответ 19 Май 2014, 15:40
от kot_oo
Как исправить при обновлении ИБ: Ошибка в запросе набора данных по причине: {(58, 2)}: Несовместимые типы "ВЫБОР" <<?>>ВЫБОР

Автор dollРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2111
Последний ответ 01 Янв 2017, 20:27
от Геннадий ОбьГЭС
"Задваивание" данных в отчете

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 7322
Последний ответ 15 Окт 2015, 11:21
от Mari_beginner
Куда сохраняются данные в режиме работы клиент при выгрузке данных обработкой "Универсальный обмен данными в формате XML"

Автор xDDРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 6948
Последний ответ 13 Ноя 2014, 08:23
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
168 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 846
  • Точка Скрытых: 0
  • Точка Пользователей: 10
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal