Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 19:09
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Усечение данных строки справа  (Прочитано 2721 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн MixanM

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-08-11
  • Сайт: 
  • Профессия: Программист 7.7
добрый день, с недавнего времени, в 1 из 7 баз, 1с начал выдать такую ошибку "22001, native 0? message [microsoft][ODBC SQL Server Driver] Усечение данных строки справа."
Процедура Выгрузить()

_конст = СоздатьОбъект("константы");
_подразделение = число(_конст.получить("идПодразделения"));
ИмяOlapТаблицыДолгов = СвойстваОбъекта(,"SQL.ИмяOlapТаблицыДолгов");
Если ПустаяСтрока(ИмяOlapТаблицыДолгов) = 1 Тогда
ИмяOlapТаблицыДолгов = "dwh..долги2";
КонецЕсли;

//мд=создатьОбъект("MetaDataWork");
тз=создатьОбъект("ТаблицаЗначений");
тз.новаяКолонка("объект","Строка",9,,,,,);
тз.новаяКолонка("дата","Дата",,,,,,);
тз.новаяКолонка("глубина","Число",3,,,,,);
тз.новаяКолонка("долг","Число",19,2,,,,);
тз.новаяКолонка("просроченно","Число",19,2,,,,);
тз.новаяКолонка("суммаКредита","Число",19,2,,,,);
//тз.новаяКолонка("проценты","Число",19,2,,,,);
тз.новаяКолонка("сумма1","Число",19,2,,,,);
тз.новаяКолонка("сумма2","Число",19,2,,,,);
тз.новаяКолонка("дебитор","Число",1,0,,,,);
тз.новаяКолонка("сумма3","Число",19,2,,,,);
тз.новаяКолонка("сумма4","Число",19,2,,,,);
тз.новаяКолонка("сумма5","Число",19,2,,,,);

фСтараяВерсия = 1;
безМинусов = 1;
толькоПросрочка = 0;
ставка = 0;
минимум = 0;
Если Сформировать(1) > 0 Тогда
Возврат;
КонецЕсли;

_б = создатьОбъект("ODBCRecordSet");
_тз = "DELETE FROM " + ИмяOlapТаблицыДолгов + " WHERE подразделение = "
+  _подразделение + " and дата = " + _датаSQL(выбКонПериода);
_б.Выполнить(_тз);
_б.Закрыть();

_б.Подготовить("INSERT INTO " + ИмяOlapТаблицыДолгов + "
|(подразделение, объект, дата, глубина, долг, просроченно, суммаКредита, сумма1, сумма2, дебитор, сумма3, сумма4, сумма5)
|VALUES("+_подразделение+", ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?)");
_б.ВыполнитьSQL_ИзТЗ(тз);

КонецПроцедуры

 
заполнение тз :
если _реж = 1 тогда
тз.новаяСтрока();
тз.объект=""+_подразделение+_объект.код;
тз.дата=выбКонПериода;
тз.глубина=_объект.вГлубина;
_вал=_объект.валюта;
тз.долг=глПересчетВалют(_долг,_вал,глРубли,,,выбКонПериода);
тз.просроченно=глПересчетВалют(_просроченно,_вал,глРубли,,,выбКонПериода);
тз.суммаКредита=глПересчетВалют(_объект.вСуммаКредита,_вал,глРубли,,,выбКонПериода);
тз.сумма1=глПересчетВалют(_сумма[1],_вал,глРубли,,,выбКонПериода);
тз.сумма2=глПересчетВалют(_сумма[2],_вал,глРубли,,,выбКонПериода);
тз.дебитор=?(_долг>0,1,0);
тз.сумма3=глПересчетВалют(_сумма[3],_вал,глРубли,,,выбКонПериода);
тз.сумма4=глПересчетВалют(_сумма[4],_вал,глРубли,,,выбКонПериода);
тз.сумма5=глПересчетВалют(_сумма[5],_вал,глРубли,,,выбКонПериода);
конецЕсли;
кто нибудь с таким сталкивался уже ???


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
180 Сообщений
ilyay ilyay
69 Сообщений
alex0402
54 Сообщений
oleg-x
48 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 275
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal