Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 20:30
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Проводка с субконто  (Прочитано 4007 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн бумер

  • *
  • Сообщений: 14
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-06
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день !
   Из таблицы выбираю строки  и программно провожу в регистр, знаю что субконто можно записать так
Проводка.СубконтоДт.вставить(ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.Номенклатура,ТекСтрока.Субконто1);
Но не всегда у счета первым субконто может быть, например, номенклатура. Подстажите пожалуйста как можно заполнить субконто регистра независимо от типа.


Оффлайн Шурыгин Иван Сергеевич

  • забей на все....
  • ****
  • Сообщений: 330
  • РЕПУТАЦИЯ: 82
  • КПД: 25%
  • забей на все!
  • Регистрация: 2011-05-23
  • Сайт: 
  • Профессия: Программист 8.1
для реализации такой функции необходимо как минимум еще и учитывать что у у некоторых счетов может вообще не оказаться субконто! это 1. второе, субконто, точнее их виды хранятся в ТЧ. так что я могу порекомендовать вот такую процедуру:

Процедура ВставитьСубконтоН(ТипДтКт,Счет,НомерСубконто,ЗначениеСубконто,Проводка)
Если НЕ (ТипДтКт = "Кт" ИЛИ ТипДтКт = "Дт") Тогда //не правильно передан тип
Возврат;
КонецЕсли;

Если Счет.Субконто.Количество() < НомерСубконто Тогда
Возврат;
//не правильно указан номер субконто
КонецЕсли;

Если НомерСубконто < 1 Тогда
//Не правильно задан номер субконто
Возврат;
КонецЕсли;

Проводка["Субконто" + ТипДтКт].Вставить(Счет.Субконто[НомерСубконто - 1].ВидСубконто,ЗначениеСубконто);
КонецПроцедуры

===================================
жизнь надо прожить так, чтоб вверху посмотрели.
и сказали "А ну ка повтори"
===================================

Оффлайн бумер

  • *
  • Сообщений: 14
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-06
  • Сайт: 
  • Профессия: Ученик 1С
Спасибо, помогло.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
163 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
36 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
28 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 327
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal