Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 20:52
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: ЧислоПрописью. Нужна помощь!!!  (Прочитано 4686 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Maxim

  • ***
  • Сообщений: 248
  • РЕПУТАЦИЯ: 10
  • КПД: 4%
  • Регистрация: 2010-11-09
  • Сайт: 
Доброго времени суток! Есть вопрос, как целую часть выводить числом?
ПарПредмета="руб.,руб.,руб.,м,коп.,коп.,коп.,ж,2";
ЧислоПрописью(1234.34, "Л = ru_RU", ПарПредмета)
При выводе:
"Одна тысяча двести тридцать четыре руб. 34 коп."
Нужно вывести т.о.:
"1234 руб. 34 коп."
Есть добровольцы??? Заранее спасибо!!!

Последний раз редактировалось: Admin; 02 Авг 2011, 12:47


Оффлайн Maxim

  • ***
  • Сообщений: 248
  • РЕПУТАЦИЯ: 10
  • КПД: 4%
  • Регистрация: 2010-11-09
  • Сайт: 
СуммаИзлишковРуб = 0;
   СуммаИзлишковКоп = 0;
   Если Найти(ИтоговыеСуммы.СуммаИзлишков,".")>0 Тогда
      СуммаИзлишковРуб = Лев(ИтоговыеСуммы.СуммаИзлишков,Найти(ИтоговыеСуммы.СуммаИзлишков,".")-1);
      СуммаИзлишковКоп = Сред(ИтоговыеСуммы.СуммаИзлишков,Найти(ИтоговыеСуммы.СуммаИзлишков,".")+1);
   Иначе
      СуммаИзлишковРуб = ИтоговыеСуммы.СуммаИзлишков;
      СуммаИзлишковКоп = Формат(0,"ЧН=00");
   КонецЕсли;
   ОбластьЗаголовокСтраницы4.Параметры.СуммаИзлишковРуб      = СуммаИзлишковРуб;
   ОбластьЗаголовокСтраницы4.Параметры.СуммаИзлишковКоп      = СуммаИзлишковКоп;

Так можно использовать?

Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Заранее спасибо!!!
Заранее пожалуйста.
Функция ПолуПропись(Сумма)	
  Рублей = Цел(Сумма);
Копеек = (Сумма-рублей)*100;
возврат ""+Рублей+" руб."+Копеек+" коп.";
КонецФункции // ПолуПропись
Кнопочка Спасибо - слева!

Оффлайн Maxim

  • ***
  • Сообщений: 248
  • РЕПУТАЦИЯ: 10
  • КПД: 4%
  • Регистрация: 2010-11-09
  • Сайт: 
Не хватает условия, но всё равно подойдёт. Ценю за Вашу помощь!

Оффлайн Maxim

  • ***
  • Сообщений: 248
  • РЕПУТАЦИЯ: 10
  • КПД: 4%
  • Регистрация: 2010-11-09
  • Сайт: 
Как-то так получилось:
Если Найти(ИтоговыеСуммы.СуммаИзлишков,".")>0 Тогда
      СуммаИзлишковРуб = Цел(ИтоговыеСуммы.СуммаИзлишков);
      СуммаИзлишковКоп = (ИтоговыеСуммы.СуммаИзлишков-СуммаИзлишковРуб)*100;
   Иначе
      СуммаИзлишковРуб = ИтоговыеСуммы.СуммаИзлишков;
      СуммаИзлишковКоп = Формат(0,"ЧН=00");
   КонецЕсли;

Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Не хватает условия, но всё равно подойдёт. Ценю за Вашу помощь!
Исправил
Функция ПолуПропись(Сумма)	
  Рублей = Цел(Сумма);
Копеек = Формат((Сумма-рублей)*100,"ЧН=00");
возврат ""+Рублей+" руб."+Копеек+" коп.";
КонецФункции // ПолуПропись
Результат
	сумма = 1234.00;
сообщить(ПолуПропись(Сумма)); = 1 234 руб.00 коп.

сумма = 1234.34;
сообщить(ПолуПропись(Сумма)); = 1 234 руб.34 коп.

Кнопочка Спасибо - слева!

Оффлайн Maxim

  • ***
  • Сообщений: 248
  • РЕПУТАЦИЯ: 10
  • КПД: 4%
  • Регистрация: 2010-11-09
  • Сайт: 
Вот это другое дело! Салют Вам!

Оффлайн Maxim

  • ***
  • Сообщений: 248
  • РЕПУТАЦИЯ: 10
  • КПД: 4%
  • Регистрация: 2010-11-09
  • Сайт: 
Ой, а если так 1234.01 -> 1 234 руб.1 коп.

Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Ой, а если так 1234.01 -> 1 234 руб.1 коп.
Функция ПолуПропись(Сумма)	
  Рублей = Цел(Сумма);
Копеек = Формат((Сумма-рублей)*100,"ЧН=00; ЧЦ=2; ЧДЦ=0; ЧВН=");
возврат ""+Рублей+" руб."+Копеек+" коп.";
КонецФункции // ПолуПропись
Кнопочка Спасибо - слева!


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
AIFrame
64 Сообщений
ilyay ilyay
63 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 276
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal