Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Май 2018, 18:56
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Запрос 8.2  (Прочитано 1634 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Vitalyos

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-08
  • Сайт: 
  • Профессия: Программист 8.1
Запрос 8.2
« Первое сообщение: 28 Июл 2011, 19:46 »
Добрый вечер, Уважаемые! Помогите начинающему программеру )))
На форме обработки есть некоторые таблицы значений. Пользователь галочками выделяет интересующие его позиции, допустим, из видов номенклатуры и маршрутов нажимает сформировать - ему выдается, допустим, список реализаций, в номенклатуре которой присутствуют выбраные виды номенклатуры. Возможно ли такой финт провернуть запросом, чтобы не перебирать вот так:

Запрос = Новый Запрос;
   Запрос.Текст = "ВЫБРАТЬ
                  |   РеализацияТоваровУслуг.Ссылка КАК Документ,
                  |   РеализацияТоваровУслуг.Контрагент,
                  |   РеализацияТоваровУслуг.АдресДоставки КАК Адрес,
                  |   ЛОЖЬ КАК Отметка
                  |ИЗ
                  |   Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
                  |
                  |УПОРЯДОЧИТЬ ПО
                  |   Документ";

   Результат = Запрос.Выполнить().Выгрузить();
   ТаблицаДокументов.Очистить();           
    МассивДоков = Новый Массив;
   Для Каждого ТекСтр Из Результат Цикл
      Докум = ТекСтр.Документ.ПолучитьОбъект();
      ЗнчСв = УправлениеСвойствами.ПолучитьЗначенияСвойств(Докум.Контрагент,Истина,Ложь);
      Для Каждого Стр из ЗнчСв Цикл
         Если Строка(Стр.Свойство)="Маршрут доставки" Тогда
            Для каждого Элемент Из Маршрут  Цикл
               Если Элемент.Пометка = Истина И (Строка(Стр.Значение) = Строка(Элемент.Значение)) Тогда
                              МассивДоков.Добавить(ТекСтр.Документ);
                        
               КонецЕсли;
            КонецЦикла;
         КонецЕсли;
      КонецЦикла;   



Теги:
 

Как можно подставлять цену из регистра сведений "Цены поставщиков" в документ"ПоступлениеТоваров" на актуальную дату? Необходимо использовать запрос в решении.

Автор Елена6666666666Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 10975
Последний ответ 24 Окт 2014, 13:30
от cska-fanat-kz
Запрос Параметры для "ИЗ"

Автор БерезинРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3364
Последний ответ 15 Май 2013, 23:27
от Березин
Что быстрее: Загрузить табличную часть в запрос и там добавить колонки, или пробежаться циклом по ТЧ и добавить значения в колонки

Автор ZeedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1227
Последний ответ 11 Июл 2016, 09:00
от vitasw
Запрос по обработке "Согласование заявок"

Автор DenielAkreedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 927
Последний ответ 29 Сен 2016, 02:39
от DenielAkreed
После "Выборка = Запрос.Выполнить().Выбрать()" строка в выборке автоматически переключается сама

Автор RuslerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 212
Последний ответ 30 Мар 2018, 05:05
от Luzer1C

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
165 Сообщений
alex0402
78 Сообщений
oleg-x
69 Сообщений
AIFrame AIFrame
63 Сообщений
buketov.av buketov.av
47 Сообщений
wise wise
39 Сообщений
ilyay ilyay
39 Сообщений
KOI8-R
36 Сообщений
Анюта17
33 Сообщений
Alter
29 Сообщений

* Кто онлайн

  • Точка Гостей: 313
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal