Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 14:11
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Нужна помощь с гиперссылкой  (Прочитано 10992 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Salima

  • *
  • Сообщений: 26
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-11
  • Сайт: 
  • Профессия: Разработчик 1С
Здравствуйте!!!
 У меня такое дело: имеется Общая форма, на которой размещена гиперссылка для перехода на Общий макет. какой код необходимо написать в обработчик события Нажатие, чтобы при нажатии на общей форме открывался общий макет?
Подскажите пожалуйста. Заранее спасибо!
"Только смелость в прохождении пути позволяет пути показать себя!"


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Процедура Нажатие(Элемент)

Макет = ПолучитьОбщийМакет("ИмяМакета");

Макет.Показать();


КонецПроцедуры
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Salima

  • *
  • Сообщений: 26
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-11
  • Сайт: 
  • Профессия: Разработчик 1С
Выходит такая ошибка:

{ОбщаяФорма.Справка.Форма(5,8)}: Процедура или функция с указанным именем не определена (ПолучитьОбщийМакет)
   Макет=<<?>>ПолучитьОбщийМакет("ПроНДС"); (Проверка: Тонкий клиент)
"Только смелость в прохождении пути позволяет пути показать себя!"

Оффлайн Salima

  • *
  • Сообщений: 26
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-11
  • Сайт: 
  • Профессия: Разработчик 1С
Что делать если тонкий клиент?
"Только смелость в прохождении пути позволяет пути показать себя!"

Оффлайн Шурыгин Иван Сергеевич

  • забей на все....
  • ****
  • Сообщений: 330
  • РЕПУТАЦИЯ: 82
  • КПД: 25%
  • забей на все!
  • Регистрация: 2011-05-23
  • Сайт: 
  • Профессия: Программист 8.1
писать функции препроцессору
&НаСервере
&НаКлиенте
===================================
жизнь надо прожить так, чтоб вверху посмотрели.
и сказали "А ну ка повтори"
===================================

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
//Пример:
&НаКлиенте
Процедура Нажатие(Элемент)

мекет = ПолучитьМойМакет();

КонецПроцедуры

&НаСервере
Функция ПолучитьМойМакет()

Макетушка = ПолучитьОбщийМакет("ИмяМакета");

Возврат Макетушка;

КонецФункции
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
//А и на клиенте открыть его.
Макет.Показать();
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Salima

  • *
  • Сообщений: 26
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-11
  • Сайт: 
  • Профессия: Разработчик 1С
Большое спасибо вам за помощь, сделала все как указано, однако выходит следующая ошибка при нажатии на гиперссылку:
Ошибка отображения типов:
Отсутствует отображение для типа 'ОболочкаHTMLДокумента'

Более подробно выходит следующее:

{ОбщаяФорма.Справка.Форма(4)}: Ошибка при вызове метода контекста (ПолучитьМойМакет)
   Макет=ПолучитьМойМакет();
по причине:
Ошибка передачи данных между клиентом и сервером. Значение недопустимого типа.
по причине:
Ошибка преобразования данных XDTO:
Запись значения свойства 'ret':
   форма: Элемент
   имя: {http://v8.1c.ru/8.2/managed-application/modules}ret
по причине:
Ошибка отображения типов:
Отсутствует отображение для типа 'ОболочкаHTMLДокумента'
"Только смелость в прохождении пути позволяет пути показать себя!"

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Весь код в студию!!!
Переменная "Макетушка" имеет тип табличный документ и он серелизуется и доступен на тонком-клиенте.
Вы кажется что то там напутали
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
еще раз код ---
[1C]&НаКлиенте
Процедура ДекорацияНажатие(Элемент)
   
   Макет = ПолучитьМакет();
   Макет.Показать();
   
КонецПроцедуры

&НаСервереБезКонтекста
Функция  ПолучитьМакет()

   Макет = ПолучитьОбщийМакет("НовыйРелиз");
   Возврат Макет;

КонецФункции
[/1C]
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
156 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
47 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 274
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal