Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
21 Янв 2018, 17:46
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: удалить запись регистра  (Прочитано 11009 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Sinsinmin

  • ***
  • Сообщений: 116
  • РЕПУТАЦИЯ: 9
  • КПД: 8%
  • Регистрация: 2010-08-11
  • Сайт: 
Подскажите как удалить запись периодического регистра подчинённого регистратору.
Погуглил, но не понимаю сути как работает.
У документа 4 регистра. В одном из них перебирая записи по условию, мне нужно удалить запись если условие истина.


Оффлайн cannabis_86

  • ***
  • Сообщений: 168
  • РЕПУТАЦИЯ: 19
  • КПД: 11%
  • Регистрация: 2010-08-26
  • Сайт: 
Запрос = Новый Запрос;
Запрос.Текст = "
|                  ВЫБРАТЬ
|                  ЦеныНоменклатурыКонтрагентов.Регистратор
|ИЗ
|                  РегистрСведений.ЦеныНоменклатурыКонтрагентов КАК ЦеныНоменклатурыКонтрагентов";

Результат = Запрос.Выполнить();
Выборка = Результат.Выбрать();

НаборЗаписей = РегистрыСведений.ЦеныНоменклатурыКонтрагентов.СоздатьНаборЗаписей();
Пока Выборка.Следующий() Цикл
                   НаборЗаписей.Отбор.Регистратор.Установить(Выборка.Регистратор);
                   НаборЗаписей.Записать();
КонецЦикла;

Оффлайн Sinsinmin

  • ***
  • Сообщений: 116
  • РЕПУТАЦИЯ: 9
  • КПД: 8%
  • Регистрация: 2010-08-11
  • Сайт: 
Как я понимаю после отбора я получаю движения Документа. Но что делает наборЗаписей. Записать() ?
Мне ведь нужно удалить одну запись регистра из 10 к примеру.

Оффлайн cannabis_86

  • ***
  • Сообщений: 168
  • РЕПУТАЦИЯ: 19
  • КПД: 11%
  • Регистрация: 2010-08-26
  • Сайт: 
Происходит запись пустых наборов движений в ИБ(очистка старых движений)

Оффлайн cannabis_86

  • ***
  • Сообщений: 168
  • РЕПУТАЦИЯ: 19
  • КПД: 11%
  • Регистрация: 2010-08-26
  • Сайт: 
Т.е. ты сперва создаешь пустой набор записей, потом делаешь отбор по своему условию и делаешь запись пустого набора.

Оффлайн Sinsinmin

  • ***
  • Сообщений: 116
  • РЕПУТАЦИЯ: 9
  • КПД: 8%
  • Регистрация: 2010-08-11
  • Сайт: 
Я получаю записи регистра для данного регистратора.

1 - А - Б - В
2 - Г - Б - В
3 - А - В - Д
4 - А - Ц - Ф

Вот я получил набор записей.
Мне нужно 2 запись удалить, а три остальных оставить. То есть регистр был из 4 записей, а станет из трёх записей.

То есть получается что я сделаю пустой набор записей. Потом вставляю в отбор условие. И по условию должно попасть что останется три записи. И потом я делаю запись регистра?

Оффлайн Sinsinmin

  • ***
  • Сообщений: 116
  • РЕПУТАЦИЯ: 9
  • КПД: 8%
  • Регистрация: 2010-08-11
  • Сайт: 
Ага происходит очистка движений. А мне нужно удалить одну строку из четырёх. Мне не нужно очищать все движения

Оффлайн cannabis_86

  • ***
  • Сообщений: 168
  • РЕПУТАЦИЯ: 19
  • КПД: 11%
  • Регистрация: 2010-08-26
  • Сайт: 
Тебе нужно сделать так, чтобы когда ты напишешь
НаборЗаписей.Отбор.Регистратор.Установить(Выборка.Регистратор);
У тебя вернулась только одна запись регистра. Соответственно тебе нужно немного изменить НаборЗаписей.Отбор. ну и тут надо посмотреть что надо поставить, чтобы выйти на эту запись твоего регистра. Посмотри как найти определенную запись регистра.

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2860
  • РЕПУТАЦИЯ: 547
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Процедура ОсновныеДействияФормыОсновныеДействияФормыВыполнить(Кнопка)
   
   Набор = РегистрыСведений.ВстречныйВыпускПродукцииУслуг.СоздатьНаборЗаписей();
   Набор.Отбор.Продукция.Установить(Перечисление);
   Набор.Прочитать();
   Для каждого х из Набор Цикл
      если х.Затрата <> Ном Тогда
         Набор.Удалить(х);
      КонецЕсли;   
   КонецЦикла;
   Набор.Записать(Истина);

                                
КонецПроцедуры

Ну как то так
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2860
  • РЕПУТАЦИЯ: 547
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Нужно оставить в набореЗаписей только то что тебе нужно удалить!!!
После записываешь и удаляться только те записи которые осталлись в наборе
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 

Как можно подставлять цену из регистра сведений "Цены поставщиков" в документ"ПоступлениеТоваров" на актуальную дату? Необходимо использовать запрос в решении.

Автор Елена6666666666Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 9738
Последний ответ 24 Окт 2014, 13:30
от cska-fanat-kz
Можно ли програмно изменить одну из колонок таблицы формы регистра сведений при создании формы

Автор RassvetniyРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 1370
Последний ответ 21 Фев 2016, 17:00
от vitasw
Запрос к виртуальной таблице регистра накопления: что писать в "Произвольном Выражении"?

Автор Светлана РождественскаяРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 198
Последний ответ 27 Окт 2017, 21:02
от MuI_I_Ika
Заполнение регистра сведений "Авансы сотрудникам организаций"

Автор rielter_alРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 1660
Последний ответ 02 Дек 2015, 11:50
от rielter_al
Верно ли, что при соединении с виртуальной таблицей остатков регистра накопления отбираются остатки по измерениям, перечисленным в условии соединения таблиц?

Автор ZeedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 773
Последний ответ 25 Ноя 2016, 11:25
от Zeed

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
100 Сообщений
AIFrame
66 Сообщений
alex0402
32 Сообщений
kiksi
26 Сообщений
pavl_vs
24 Сообщений
alexandr_ll
18 Сообщений
andron81_81
16 Сообщений
Norfolk
16 Сообщений
KOI8-R
14 Сообщений
MuI_I_Ika MuI_I_Ika
13 Сообщений

* Кто онлайн

  • Точка Гостей: 379
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal