Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 19:10
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Траблы при неопер проведении  (Прочитано 1704 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн MevMix

  • *
  • Сообщений: 42
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-21
  • Сайт: 
  • Профессия: Программист 8.1
Добрый день!!! Конфиг пишется мною 1с 8.1.

при опертивноп проведении все ОК списывает то количество что надо при не оперативном
в несколько раз больше и даже не то что в табличной части, а еще как то сам выбирает и списывает
На скрине комплектация, снизу движение по регистру
3 первый ОК остальное берет сам при проведении.
Если НЕ Отказ Тогда
Запрос = Новый Запрос;
Если Режим = РежимПроведенияДокумента.Оперативный Тогда
Запрос.Текст  =
"ВЫБРАТЬ
| КомплектацияНоменклатурыПереченьНоменклатуры.Номенклатура,
| КомплектацияНоменклатурыПереченьНоменклатуры.Количество,
| КомплектацияНоменклатурыПереченьНоменклатуры.Номенклатура.ВидНоменклатуры КАК ВидНоменклатуры,
| ОстаткиТоваровОстатки.КоличествоОстаток,
| ОстаткиТоваровОстаткиНаСкладе.КоличествоОстаток КАК КоличествоОстатокНаСкладе
|ИЗ
| Документ.КомплектацияНоменклатуры.ПереченьНоменклатуры КАК КомплектацияНоменклатурыПереченьНоменклатуры
| ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакопления.ОстаткиТоваров.Остатки(
| &МоментВремени,
| Номенклатура В (&СписокНоменклатурыДокумента)
| И Склад = &СкладВДокументе) КАК ОстаткиТоваровОстаткиНаСкладе
| ПО КомплектацияНоменклатурыПереченьНоменклатуры.Номенклатура = ОстаткиТоваровОстаткиНаСкладе.Номенклатура
| ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакопления.ОстаткиТоваров.Остатки(
| &МоментВремени,
| Номенклатура В (&СписокНоменклатурыДокумента)
| И Склад = &СкладВДокументе) КАК ОстаткиТоваровОстатки
| ПО КомплектацияНоменклатурыПереченьНоменклатуры.Номенклатура = ОстаткиТоваровОстатки.Номенклатура
|ГДЕ
| КомплектацияНоменклатурыПереченьНоменклатуры.Ссылка = &Ссылка
|
|ДЛЯ ИЗМЕНЕНИЯ
| РегистрНакопления.ОстаткиТоваров.Остатки";
Иначе
Запрос.Текст  =
"ВЫБРАТЬ
| КомплектацияНоменклатурыПереченьНоменклатуры.Номенклатура,
| КомплектацияНоменклатурыПереченьНоменклатуры.Количество,
| КомплектацияНоменклатурыПереченьНоменклатуры.Номенклатура.ВидНоменклатуры КАК ВидНоменклатуры,
| ОстаткиТоваровОстатки.КоличествоОстаток
|ИЗ
| Документ.КомплектацияНоменклатуры.ПереченьНоменклатуры КАК КомплектацияНоменклатурыПереченьНоменклатуры
| ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакопления.ОстаткиТоваров.Остатки(&МоментВремени, Номенклатура В (&СписокНоменклатурыДокумента)) КАК ОстаткиТоваровОстатки
| ПО КомплектацияНоменклатурыПереченьНоменклатуры.Номенклатура = ОстаткиТоваровОстатки.Номенклатура
|
|ДЛЯ ИЗМЕНЕНИЯ
| РегистрНакопления.ОстаткиТоваров.Остатки"
КонецЕсли;
Запрос.УстановитьПараметр("СкладВДокументе", Склад);
Запрос.УстановитьПараметр("МоментВремени", МоментВремени());
Запрос.УстановитьПараметр("СписокНоменклатурыДокумента", ПереченьНоменклатуры.ВыгрузитьКолонку("Номенклатура"));
Запрос.УстановитьПараметр("Ссылка", Ссылка);

ВыборкаРезультатаЗапроса = Запрос.Выполнить().Выбрать();

Пока ВыборкаРезультатаЗапроса.Следующий() Цикл
// Проверить остаток при оперативном проведении.
Если Режим = РежимПроведенияДокумента.Оперативный Тогда
Если ВыборкаРезультатаЗапроса.ВидНоменклатуры = Перечисления.ВидыНоменклатуры.Номенклатура Тогда
Остаток = ?(ВыборкаРезультатаЗапроса.КоличествоОстаток = Null, 0, ВыборкаРезультатаЗапроса.КоличествоОстаток);
Если Остаток < ВыборкаРезультатаЗапроса.Количество или Остаток = 0 Тогда
Сообщить("Недостаточное количество на склдаде "+Склад+" :"+СокрЛП(ВыборкаРезультатаЗапроса.Номенклатура) + ", в наличии только " + Остаток);
Отказ = Истина;
Возврат;
КонецЕсли;
КонецЕсли;
КонецЕсли;

Если ВыборкаРезультатаЗапроса.ВидНоменклатуры = Перечисления.ВидыНоменклатуры.Номенклатура Тогда

Движение = Движения.ОстаткиТоваров.Добавить();
Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
Движение.Период = Дата;
Движение.Номенклатура = ВыборкаРезультатаЗапроса.Номенклатура;
Движение.Склад = Склад;
Движение.Количество = ВыборкаРезультатаЗапроса.Количество;
КонецЕсли;
КонецЦикла;
Движение = Движения.ОстаткиТоваров.Добавить();
Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
Движение.Период = Дата;
Движение.Номенклатура = Комплект;
Движение.Склад = Склад;
Движение.Количество = Количество;

Движения.ОстаткиТоваров.Записать();
КонецЕсли;


Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Что то во втором запросе не видно условия на ссылку документа.
Кнопочка Спасибо - слева!

Оффлайн MevMix

  • *
  • Сообщений: 42
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-21
  • Сайт: 
  • Профессия: Программист 8.1
Тему мона закрыатьнет во втором запросе
|ГДЕ
| КомплектацияНоменклатурыПереченьНоменклатуры.Ссылка = &Ссылка


Теги:
 

Как в 1С 8.2 при проведении документа заполнить элемент справочника информацией из документа?

Автор Галина55555Раздел Беседка

Ответов: 1
Просмотров: 5563
Последний ответ 01 Июл 2014, 16:44
от Галина55555
Ошибка в проведении документа "Оказание Услуг"

Автор NollaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 337
Последний ответ 30 Сен 2017, 23:44
от Nolla
выводит ошибку при проведении документа "Оплаты праздничных и выходных дней"

Автор bannovРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 2558
Последний ответ 06 Июл 2010, 14:46
от bannov
ПРОБЛЕМА!!!( при проведении документа"Реализация" выдается ошибка)

Автор Syuz79Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1736
Последний ответ 22 Мар 2012, 14:17
от Vit1501
Ошибка при проведении документа "Реализация товаров и услуг"

Автор PowerLordРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 1208
Последний ответ 21 Июл 2013, 15:44
от PowerLord

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
AIFrame
63 Сообщений
ilyay ilyay
63 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 279
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal