Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Июл 2019, 02:20
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: отбор-фильтр в таб. поле формы связанной с реквизитом формы  (Прочитано 629 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн andron81_81

  • ***
  • Сообщений: 181
  • РЕПУТАЦИЯ: -2
  • Регистрация: 2015-09-17
  • Сайт: 
  • Профессия: Ученик 1С
(8)
Ещё раз последняя часть так же должна присуствовать в ТЗ. это можно реализовать путем "Найти" или "НайтиСтроки" ?
НайтиСтроки возвращает МассивСтрок... Скрывай ОсновнуюТаблицу и отображай ТаблицуИзМассива, и при отображении ТаблицыИзМассива показывай кнопку "Очистить фильтр", которая будет очищать и скрывать ТаблицуИзМассива и ВНОВЬ показывать ОсновнуюТаблицу... :P



в целом все участники молодцы, помогли - спасибо ! :zebzdr:
вышло вот так по советам. на форме таб. поле и две кнопки. одна отображает значения где Отображать = истина, другая наоборот. в них же я и обновляю переменную "Табличка" .
Всё ли корректно понял/сделал ? или можно проще (обновление таблицы значений "Табличка") ?

 перем Табличка ;
Процедура ПриОткрытии()
Табличка = Новый ТаблицаЗначений();
Табличка.Колонки.Добавить("Наименование",Новый ОписаниеТипов("Строка"));
Табличка.Колонки.Добавить("Цвет",Новый ОписаниеТипов("Строка"));
Табличка.Колонки.Добавить("Отображать",Новый ОписаниеТипов("Булево"));
Табличка.Колонки.Добавить("БылоИзменение",Новый ОписаниеТипов("Булево"));

НоваяСтрокаТаблицы = Табличка.Добавить();
НоваяСтрокаТаблицы.Наименование="Яблока";
НоваяСтрокаТаблицы.Цвет="красное";
НоваяСтрокаТаблицы.Отображать="Истина";
НоваяСтрокаТаблицы.БылоИзменение="Ложь";


НоваяСтрокаТаблицы = Табличка.Добавить();
НоваяСтрокаТаблицы.Наименование="Груша";
НоваяСтрокаТаблицы.Цвет="зеленый";
НоваяСтрокаТаблицы.Отображать="Истина";
НоваяСтрокаТаблицы.БылоИзменение="Ложь";
НоваяСтрокаТаблицы = Табличка.Добавить();
НоваяСтрокаТаблицы.Наименование="Виноград";
НоваяСтрокаТаблицы.Цвет="зеленый";
НоваяСтрокаТаблицы.Отображать="Истина";
НоваяСтрокаТаблицы.БылоИзменение="Ложь";
НоваяСтрокаТаблицы = Табличка.Добавить();
НоваяСтрокаТаблицы.Наименование="Клубника";
НоваяСтрокаТаблицы.Цвет="красный";
НоваяСтрокаТаблицы.Отображать="Ложь";
НоваяСтрокаТаблицы.БылоИзменение="Ложь";
   Отбор = Новый Структура ("Отображать",Истина);
   
   ОтфильтрованнаяТаблица = Новый ТаблицаЗначений();
   ОтфильтрованнаяТаблица = Табличка.Скопировать(Отбор);
   
   

ЭтаФорма.ЭлементыФормы.ТабличноеПоле1.Значение = ОтфильтрованнаяТаблица;




КонецПроцедуры

Процедура ИстинаНажатие(Элемент)

ОтборИзмененныхПолей = Новый Структура ("БылоИзменение",Истина);
  БылиИзмененияТаблица = ЭтаФорма.ЭлементыФормы.ТабличноеПоле1.Значение.НайтиСтроки(ОтборИзмененныхПолей);
 
 Для Каждого СтрокаБылиИзмененияТаблица из БылиИзмененияТаблица Цикл
       
Табличка.Найти( СтрокаБылиИзмененияТаблица.Наименование ).Цвет = СтрокаБылиИзмененияТаблица.Цвет;
//СтрокаБылиИзмененияТаблица);
    КонецЦикла;  
 
  //Табличка.Скопировать(Отбор);

Отбор = Новый Структура ("Отображать",Истина);
   
   ОтфильтрованнаяТаблица = Новый ТаблицаЗначений();
   ОтфильтрованнаяТаблица = Табличка.Скопировать(Отбор);
   
ЭтаФорма.ЭлементыФормы.ТабличноеПоле1.Значение = ОтфильтрованнаяТаблица;


КонецПроцедуры

Процедура ЛожьНажатие(Элемент)


ОтборИзмененныхПолей = Новый Структура ("БылоИзменение",Истина);
  БылиИзмененияТаблица = ЭтаФорма.ЭлементыФормы.ТабличноеПоле1.Значение.НайтиСтроки(ОтборИзмененныхПолей);
 
 Для Каждого СтрокаБылиИзмененияТаблица из БылиИзмененияТаблица Цикл
       
Табличка.Найти( СтрокаБылиИзмененияТаблица.Наименование ).Цвет = СтрокаБылиИзмененияТаблица.Цвет;
//СтрокаБылиИзмененияТаблица);
    КонецЦикла;  


Отбор = Новый Структура ("Отображать",Ложь);
   
   ОтфильтрованнаяТаблица = Новый ТаблицаЗначений();
   ОтфильтрованнаяТаблица = Табличка.Скопировать(Отбор);
   
ЭтаФорма.ЭлементыФормы.ТабличноеПоле1.Значение = ОтфильтрованнаяТаблица;



КонецПроцедуры

Процедура ТабличноеПоле1ЦветПриИзменении(Элемент)
ЭтаФорма.ЭлементыФормы.ТабличноеПоле1.ТекущиеДанные.БылоИзменение=Истина;
КонецПроцедуры

не уверен , что кто-то будет скачивать, но инфобазу прилагаю на всякий, если что :)


Последний раз редактировалось: andron81_81; 13 Дек 2018, 22:18


 

Поле не найдено"ЗаказПокупателя.Услуги.Ссылка"<<?>>ЗаказПокупателя.Услуги.Ссылка

Автор romanprogrammistРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 8635
Последний ответ 05 Дек 2013, 00:01
от romanprogrammist
{Форма.Форма.Форма(11)}: Поле объекта не обнаружено

Автор OksРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3395
Последний ответ 09 Дек 2015, 19:33
от Oks
Вывод информации: если поле не заполнено, то вывод иной информации. Новичок

Автор kiksiРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 1968
Последний ответ 10 Окт 2017, 12:33
от kiksi
Добавить поле "Свойство" в "Печать прайс-листа"

Автор useronforumРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 810
Последний ответ 24 Фев 2018, 14:40
от useronforum
Добавить поле "Комментарий" в "Печать прайс-листа"

Автор useronforumРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 769
Последний ответ 03 Мар 2018, 16:14
от useronforum

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

MuI_I_Ika MuI_I_Ika
66 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
60 Сообщений
LexaK
23 Сообщений
DmitriyF DmitriyF
17 Сообщений
wise wise
15 Сообщений
Александр Мун Александр Мун
14 Сообщений
alex0402 alex0402
11 Сообщений
Мария112689
11 Сообщений
BuhRust
10 Сообщений
alexandr_ll
8 Сообщений

* Кто онлайн

  • Точка Гостей: 193
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal