Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Сен 2019, 17:53
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как выгрузить элемент справочника "контрагенты" в файл XML  (Прочитано 1236 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ЕвгенийЗерно

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2017-06-08
  • Сайт: 
  • Профессия: Программист 1С
Добрый день! Подскажите как выгрузить элемент справочника "контрагенты" в файл XML, с учетом того, что выгружать данные контрагента, нужно того, который выбран в документе. Например: Есть документа, в нем выбран контрагент из справочника "Контрагенты", как мне выгрузить в файл его ИНН. Выгрузка происходит при нажатии кнопки в форме этого документа.

Получился приблизительно такой код, но он естественно не работает, помогите сделать правильно:
&НаКлиенте
Процедура Выгрузка()
   
Запись=Новый ЗаписьXML;
Запись.ОткрытьФайл("D:\document.xml", "UTF-8");
Запись.ЗаписатьОбъявлениеXML();
Запись.ЗаписатьНачалоЭлемента("Корневой");
Запись.ЗаписатьАтрибут("Доумент", "Взвешивание");

 Выборка = Справочники.Номенклатура.Выбрать();
 Запись.ЗаписатьНачалоЭлемента("Код");
 Запись.Записать(Выборка.Код);
 Запись.ЗаписатьКонецЭлемента();

 Запись.Закрыть();
 Сообщить("Выгружено");
КонецПроцедуры

Как мне обратится к открытому документу, выбрать поле справочника и из него выбрать ИНН и записать в XML?

Последний раз редактировалось: ЕвгенийЗерно; 23 Июл 2018, 15:43


Оффлайн wise

  • *****
  • Сообщений: 902
  • РЕПУТАЦИЯ: 131
  • КПД: 15%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
(0) можно через "Объект"

&НаКлиенте
Процедура Выгрузка()
   
Запись=Новый ЗаписьXML;
Запись.ОткрытьФайл("D:\document.xml", "UTF-8");
Запись.ЗаписатьОбъявлениеXML();
Запись.ЗаписатьНачалоЭлемента("Корневой");
Запись.ЗаписатьАтрибут("Доумент", "Взвешивание");

 //Выборка = Справочники.Номенклатура.Выбрать();
 Запись.ЗаписатьНачалоЭлемента("Клиент");
 Запись.ЗаписатьТекст(XMLСтрока(Объект.Партнер));
 Запись.ЗаписатьКонецЭлемента();

 Запись.Закрыть();
 Сообщить("Записано !");
КонецПроцедуры
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Оффлайн ЕвгенийЗерно

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2017-06-08
  • Сайт: 
  • Профессия: Программист 1С
(0) можно через "Объект"

&НаКлиенте
Процедура Выгрузка()
   
Запись=Новый ЗаписьXML;
Запись.ОткрытьФайл("D:\document.xml", "UTF-8");
Запись.ЗаписатьОбъявлениеXML();
Запись.ЗаписатьНачалоЭлемента("Корневой");
Запись.ЗаписатьАтрибут("Доумент", "Взвешивание");

 //Выборка = Справочники.Номенклатура.Выбрать();
 Запись.ЗаписатьНачалоЭлемента("Клиент");
 Запись.ЗаписатьТекст(XMLСтрока(Объект.Партнер));
 Запись.ЗаписатьКонецЭлемента();

 Запись.Закрыть();
 Сообщить("Записано !");
КонецПроцедуры

Но ведь мне нужно записать не самого Контрагента (в вашем случае Партнера), а элемент этого справочника ( его ИНН). Как обратится к реквизиту этого партнера ,который заносили в справочник "контрагенты"?
Добавлено: 24 Июл 2018, 09:11

(0) можно через "Объект"

&НаКлиенте
Процедура Выгрузка()
   
Запись=Новый ЗаписьXML;
Запись.ОткрытьФайл("D:\document.xml", "UTF-8");
Запись.ЗаписатьОбъявлениеXML();
Запись.ЗаписатьНачалоЭлемента("Корневой");
Запись.ЗаписатьАтрибут("Доумент", "Взвешивание");

 //Выборка = Справочники.Номенклатура.Выбрать();
 Запись.ЗаписатьНачалоЭлемента("Клиент");
 Запись.ЗаписатьТекст(XMLСтрока(Объект.Партнер));
 Запись.ЗаписатьКонецЭлемента();

 Запись.Закрыть();
 Сообщить("Записано !");
КонецПроцедуры

Но ведь мне нужно записать не самого Контрагента (в вашем случае Партнера), а элемент этого справочника ( его ИНН). Как обратится к реквизиту этого партнера ,который заносили в справочник "контрагенты"?

Добавил ИНН и получилось  Запись.ЗаписатьТекст(XMLСтрока(Объект.Партнер));
Спасибо.
Подскажите пожалуйста как теперь выгрузить его Адрес, ведь он является не полем ввода, а полем выбора, где в форме указываем в свободной форме Юридический адрес.Представление. Как к нему обратиться и выгрузить его?

Последний раз редактировалось: ЕвгенийЗерно; 24 Июл 2018, 09:11. Причина: Объединение сообщений


Теги:
 

Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 5774
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2551
Последний ответ 10 Май 2017, 20:44
от ilnur75
Загрузка из Excel , Загрузка справочника физ.лица и сотрудники

Автор yojРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 1217
Последний ответ 24 Янв 2018, 02:55
от Геннадий ОбьГЭС
Заполнение полей документа данными другого документа/справочника

Автор Георгий ШиринкинРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2391
Последний ответ 20 Май 2016, 09:40
от Георгий Ширинкин
УТ 11.1 Как изменить единицу хранения у номенклатуры после перброса справочника номенклатуры в чистую базу

Автор pavel-PРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 6027
Последний ответ 12 Дек 2014, 20:15
от SitnovaMarina

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
83 Сообщений
LexaK
58 Сообщений
Yamuna
35 Сообщений
alexandr_ll
26 Сообщений
DmitriyF DmitriyF
23 Сообщений
Funt432286
23 Сообщений
antoneus antoneus
22 Сообщений
KOI8-R
18 Сообщений
MuI_I_Ika MuI_I_Ika
18 Сообщений
alex0402 alex0402
17 Сообщений

* Кто онлайн

  • Точка Гостей: 448
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal