Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Сен 2019, 17:48
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как исправить при обновлении ИБ: Ошибка в запросе набора данных по причине: {(58, 2)}: Несовместимые типы "ВЫБОР" <<?>>ВЫБОР  (Прочитано 3640 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн doll

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 1
  • КПД: 14%
  • Регистрация: 2017-01-01
  • Сайт: 
  • Профессия: Программист 1С
Добрый день! С Новым Годом! Помогите, пожалуйста, решить задачу:

При установке модуля обмена с Битрикс на 1С предприятие 8.3.8.1784 Конфигурация УТ 11.2 делала по инструкции отладку с параметром "ЗапуститьОбновлениеИнформационнойБазы". Программа не дает завершить обновление по причине ошибки: "Ошибка в схеме компоновки данных
по причине:
Ошибка получения информации набора данных
по причине:
Ошибка в запросе набора данных
по причине:
{(58, 2)}: Несовместимые типы "ВЫБОР"
<<?>>ВЫБОР"

Данная ошибка в Общем модуле. Длительность операции. 376 строка. Вот текст (376 строка отмечена цифрой):

Функция ЗаданиеВыполнено(Знач ИдентификаторЗадания) Экспорт
   
   Задание = НайтиЗаданиеПоИдентификатору(ИдентификаторЗадания);
   
   Если Задание <> Неопределено
      И Задание.Состояние = СостояниеФоновогоЗадания.Активно Тогда
      Возврат Ложь;
   КонецЕсли;
   
   ОперацияНеВыполнена = Истина;
   ПоказатьПолныйТекстОшибки = Ложь;
   Если Задание = Неопределено Тогда
      ЗаписьЖурналаРегистрации(НСтр("ru = 'Длительные операции.Фоновое задание не найдено'", ОбщегоНазначенияКлиентСервер.КодОсновногоЯзыка()),
         УровеньЖурналаРегистрации.Ошибка, , , Строка(ИдентификаторЗадания));
   Иначе
      Если Задание.Состояние = СостояниеФоновогоЗадания.ЗавершеноАварийно Тогда
         ОшибкаЗадания = Задание.ИнформацияОбОшибке;
         Если ОшибкаЗадания <> Неопределено Тогда
            ПоказатьПолныйТекстОшибки = Истина;
         КонецЕсли;
      ИначеЕсли Задание.Состояние = СостояниеФоновогоЗадания.Отменено Тогда
         ЗаписьЖурналаРегистрации(
            НСтр("ru = 'Длительные операции.Фоновое задание отменено администратором'", ОбщегоНазначенияКлиентСервер.КодОсновногоЯзыка()),
            УровеньЖурналаРегистрации.Ошибка,
            ,
            ,
            НСтр("ru = 'Задание завершилось с неизвестной ошибкой.'"));
      Иначе
         Возврат Истина;
      КонецЕсли;
   КонецЕсли;
   
   Если ПоказатьПолныйТекстОшибки Тогда
       ТекстОшибки = КраткоеПредставлениеОшибки(ПричинаОшибки(Задание.ИнформацияОбОшибке));
376   ВызватьИсключение (ТекстОшибки);
   ИначеЕсли ОперацияНеВыполнена Тогда
      ВызватьИсключение(НСтр("ru = 'Не удалось выполнить данную операцию.
                            |Подробности см. в Журнале регистрации.'"));
   КонецЕсли;
   
КонецФункции

#КонецОбласти


Оффлайн Геннадий ОбьГЭС

  • Консультант-программист 1С. ЗВОНИТЕ!
  • *****
  • Сообщений: 3151
  • РЕПУТАЦИЯ: 133
  • КПД: 4%
  • Проблемы реш удаленно проблемы в 1С
  • Регистрация: 2015-03-12
  • Сайт: nsk1c.wordpress.com
  • Профессия: Программист 1С
Геннадий
(Консультант-программист 1С.
Решаю проблемы учёта дёшево!
Ищу работу недалеко от ОбьГЭС)

Оффлайн ДТК

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2018-03-25
  • Сайт: 
  • Профессия: Программист 1С

Оффлайн AIFrame

  • *****
  • Сообщений: 1396
  • РЕПУТАЦИЯ: 182
  • КПД: 13%
  • Регистрация: 2015-07-22
  • Сайт: 
  • Профессия: Программист 1С
Данная ошибка в Общем модуле. Длительность операции. 376 строка. Вот текст (376 строка отмечена цифрой):
Она не там, а до этого момента. Где-то есть запрос кривой.
Поставь точку останова на 376 строке, выдели Задание.ИнформацияОбОшибке и нажми shift+f9, хоть текст посмотришь.

Оффлайн Геннадий ОбьГЭС

  • Консультант-программист 1С. ЗВОНИТЕ!
  • *****
  • Сообщений: 3151
  • РЕПУТАЦИЯ: 133
  • КПД: 4%
  • Проблемы реш удаленно проблемы в 1С
  • Регистрация: 2015-03-12
  • Сайт: nsk1c.wordpress.com
  • Профессия: Программист 1С
Геннадий
(Консультант-программист 1С.
Решаю проблемы учёта дёшево!
Ищу работу недалеко от ОбьГЭС)


Теги: обновление 
 

Закрытие месеца, ошибка при закрытие 26сч

Автор GendelfРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 5056
Последний ответ 26 Июл 2013, 11:00
от Gendelf
ОШИБКА 1С 8.3. Файл не найден в хранилище файлов. Возможно файл удален антивирусной программой. Обратитесь к администратору

Автор Сергей БатуринРаздел Пользователям "1С - Предприятие 8"

Ответов: 6
Просмотров: 11159
Последний ответ 18 Май 2016, 18:18
от Сергей Батурин
При попытке проведения документов по НДФЛ (справка 2 НДФЛ ) вылезает ошибка:

Автор klaus38Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 3547
Последний ответ 19 Фев 2015, 20:54
от vitasw
При входе пользователя 1с77 по RDP (Server2008) выдается ошибка и выпадает 1с77

Автор ktu78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2508
Последний ответ 07 Дек 2016, 09:17
от alex0402
Перенос данных из 1с 82 БП (базовая) в 1с 82 БГУ (базовая)

Автор Владимир87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 8943
Последний ответ 06 Дек 2014, 17:40
от дфтын

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
83 Сообщений
LexaK
58 Сообщений
Yamuna
35 Сообщений
alexandr_ll
26 Сообщений
DmitriyF DmitriyF
23 Сообщений
Funt432286
23 Сообщений
antoneus antoneus
22 Сообщений
KOI8-R
18 Сообщений
MuI_I_Ika MuI_I_Ika
18 Сообщений
alex0402 alex0402
17 Сообщений

* Кто онлайн

  • Точка Гостей: 487
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal